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Welcome to Coastal Explorer 

Thank you for choosing Coastal Explorer! 

If you are new to navigation software, but use a computer for anything else, you will find that Coastal Explorer 
works just like many other Windows applications: you create documents, edit them, save them, print them, etc. 
The big difference is that Coastal Explorer’s documents contain navigation objects such as routes and waypoints 
rather than paragraphs or spread-sheet cells. 

If you already use another navigation program this might seem strange at first as most other systems keep all of 
your navigation objects in a single database rather than in document files. We expect that you will quickly come 
to appreciate the benefits of using documents as you can more easily organize, backup, and even e-mail your 
routes and other objects using familiar Windows commands. 

Coastal Explorer includes many other features that make it seem more like other Windows applications than 
most navigation systems do. These features include the familiar clipboard operations Cut, Copy, and Paste, 
multi-level Undo and Redo commands, and a Find command. 

While we have tried to make Coastal Explorer as easy to use as possible, we have not skimped on the features! 
Coastal Explorer is a very powerful planning and navigation tool. Here are just some of the powerful features 
you will soon be using: 

 Quilted vector and raster charts, photo charts, and topographic maps 

 Fast and easy panning and zooming 

 Split-screen chart viewing 

 Instant access to the information contained in your charts and guide books 

 Unlimited routes and waypoints 

 Route checking and obstacle alerts 
 Virtual Instrument displays 

 Autopilot control 

 Full-screen customizable Cruising Mode 

 Chart Portfolio Management 

 Tide and current predictions 

 Optional Radar display and chart overlay 
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How to Use This Book 

Here are some terms and conventions we used in making this book. 

Hover means to point at something with the mouse and then stop moving the mouse for a few seconds. 

Click means to point at something with the mouse then press and release a mouse button. If we don’t say 
otherwise, then we mean the left-most button. 

Right-Click means to press and release the right-most mouse button. This is a common operation to access 
popup menus. 

Drag means to press and hold the mouse button while moving the mouse and releasing the button when you 
are done. Dragging is usually done with the left-most button. 

Press and Hold means to press and hold the mouse button for a few seconds without moving the mouse. This is 
usually done with the left-most button. 

We use a shortcut convention to point out where you can find commands. Rather than saying “Click on the Tools 
menu, then the Options command, then the Instruments tab, and then the Troubleshooter button,” we will say 
“Select the Tools > Options > Instruments > Troubleshooter command.” 

Using Coastal Explorer’s Help System 
Most of the contents of this book, plus any updated material that might become available, is included in Coastal 
Explorer’s online help system. You can access help by using the Help > Contents and Index option in Coastal 
Explorer. The F1 key will also open the help window, and usually select the topic most relevant to what you are 
doing. 
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Installing Coastal Explorer 

System Requirements 
The minimum system requirements to use Coastal Explorer are: 

 PC running Microsoft Windows 2000, Microsoft Windows XP, Microsoft Windows Vista, or a newer 
compatible operating system. 

 128MB of Memory; 512MB or more is recommended. 

 50MB Available Hard Drive Space; 500MB for a Full Installation and more for charts. 

 Video display with at least 800x600 pixel resolution and 16-bit color (Thousands of Colors); 1024x768 or 
higher with 24-bit color (Millions of Colors) is recommended. 

 Mouse or other pointing device; a scroll-wheel is recommended. 

Some features require: 

 NMEA 0183 compatible GPS with suitable PC interface 

 NMEA 0183 compatible autopilot with suitable PC interface 

 Other NMEA 0183 compatible equipment 

 NMEA 2000 compatible equipment and a suitable PC interface. 

 Rose Point Radar Sensor 

Installing the Software 
When you insert the Coastal Explorer program CD into your disc drive the setup program should run 
automatically. If the AutoRun feature is disabled on your CD-ROM drive you will need to open the disc and run 
the Setup program found there. 

The setup program will guide you through the installation process. Several features are optional and the setup 
program will allow you to choose which ones you want to install. The optional features include: 

High-Resolution World Base Map – Coastal Explorer includes a “background” map of the world’s coastlines that 
helps you keep your bearings when viewing an area where you do not have chart coverage. The world map is 
always available, but this option will make it appear less “chunky” when viewed at larger scales. Turn this option 
off if you need the disc space (it uses about 100MB). 

Gazetteer – The gazetteer lists millions of places in the United States, Canada, and Mexico. You can quickly and 
easily search for any of these places if you install the appropriate lists. During setup, you can decide whether or 
not to include each US state, Canada, and Mexico. The size of each list is shown in the setup program. 

Guide Books – The Coast Pilot and Sailing Directions information is stored in several separate “books” organized 
by area. You can install all of the books or just the ones with the information you might use. Each book needs 1-
2MB. 

Installing or Removing Optional Features 
If you decline to install some options at setup time, but decide later that you’d like to have them, simply run the 
setup program again. You can also remove options that have been installed but are no longer needed.  

Removing Coastal Explorer from Your Computer 

Use the Add/Remove Programs option in the Windows Control Panel to uninstall Coastal Explorer. Uninstalling 
Coastal Explorer will remove the software, world base map, gazetteer, guide books, weather files, and other files 
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that can be restored by running setup again. Your charts and navigation object documents are not removed by 
the uninstall program. 

Getting Program Updates 

Coastal Explorer has a built-in, semi-automatic update mechanism to help ensure you are always using the latest 
and greatest version. 

When you use Coastal Explorer on a computer that is connected to the Internet, it will automatically try to 
download the latest update. The next time you start Coastal Explorer after an automatic download you will be 
asked if you want to install the update. 

You can also get Coastal Explorer to start your dial-up Internet connection, or just force a check and update at 
any time by using the Help > Check for Updates command. 

If you need to update a computer that does not have access to the Internet, you can download an update file 
onto a floppy disk, flash memory key, or other portable storage device from our website at 
http://updates.coastalexplorer.net/. 
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Using Coastal Explorer 

Starting Coastal Explorer 

 

Once you’ve installed Coastal Explorer, you can find it on the Windows Start menu in the All Programs list. The 
setup program will also offer to create an icon on your desktop for you. 

You can also start Coastal Explorer by opening a navigation object document such as one in your My Documents 
folder or one sent to you as an e-mail attachment. Just double-click on the document’s icon and Coastal Explorer 
will start up and load that document. 

When Coastal Explorer starts up, it will offer to install any updates that were downloaded during a previous 
session. If anything in your chart folders has changed, the chart portfolio will be updated next. After that the last 
navigation object document that you were using is opened (unless you started Coastal Explorer by opening a 
different document). 

Operating Modes 
Coastal Explorer was primarily designed to help you do two things: plan a voyage and navigate that plan. These 
two activities can require different tools, so Coastal Explorer has two modes: Planning Mode and Cruising 
Mode.  

In Planning Mode, Coastal Explorer looks and works much like any other Windows application. It provides tools 
for creating Routes and other Navigation Objects, getting information from Charts and Guide Books, and finding 
places in the Gazetteer.  

In Cruising Mode, Coastal Explorer takes over most of the screen and hides the title bar, menu bar, and standard 
toolbars in order to give you more chart area on the screen. Commands are made available via larger toolbars 
that are easier to use while underway and provide quick access to the functions you need most.  

You can switch between Planning Mode and Cruising Mode at any time by pressing the F12 key. While in 
Planning Mode, you can switch to Cruise Mode by using the Cruise Mode command on the Tools menu. Cruise 
Mode will be automatically activated if your boat starts moving faster than 1 knot according to a GPS or other 
instrument connected to your computer. Once in Cruise Mode you can switch back to Planning Mode by clicking 
on the Coastal Explorer logo in the top-left corner of the screen, and selecting Planning Mode from the menu 
that appears.  
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Introduction to Planning Mode 

Planning Mode is the initial mode of operation for Coastal Explorer. This is where you can easily create, open, 
and save documents, create routes, marks, boundaries, and other navigation objects, find places by name, and 
access all of the other planning features of Coastal Explorer. 

Here is a snapshot of a typical Coastal Explorer screen while in Planning Mode: 

 

REVIEW: This picture needs captions and arrows pointing at the various parts! 

In the rest of this manual, we will refer to several parts of the window which we will name here. 

Like most applications, Coastal Explorer has a title bar at the top of its window that indicates the name of the 
program and the name of the current chart window. Below that is the menu bar which provides easy access to 
many of the program's functions. Then there are two toolbars; the main toolbar on top, and the Navigation 
Object toolbar below that. 

The bulk of the screen is taken up by the Chart Viewing Area. Inside the Chart Viewing Area is a yellow Chart Tip 
and below it is the Browser. To the right of the Chart Viewing Area is the Chart Overview and the Task Pane area 
which is showing the Properties Task Pane. Finally, at the bottom of the window is a status bar. 

All of the work you do in Planning Mode is saved in documents called Navigation Object Files. Like any Word 
Processor or Spreadsheet program, you can have as many different documents as you like, and you would 
typically save them in your My Documents folder. When you start Coastal Explorer it will automatically open the 
last document you were using. 
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Menu Commands 

The menubar normally appears near the top of the Coastal Explorer window just like in any other Windows 
program. However, in Cruise Mode and Full Screen Mode, the menubar and standard toolbars are not displayed. 
When using these modes, you can make the menubar appear temporarily by moving your mouse cursor to the 
top of the screen. 

The File Menu 
New Creates a new Navigation Object File 

Open... Opens an existing Navigation Object File 

Save Saves the currently open Navigation Object File 

Save As... Saves the currently open Navigation Object File as a new file 

Page Setup... Set print options such as page orientation and margins 

Print Preview Previews a print operation on the screen 

Print... Prints the current chart view 

Send To Sends a copy of the current Navigation Object File as e-mail or to portable storage 

Import... Import Navigation Objects from a file or your GPS/Chartplotter 

Export... Export Navigation Objects to a separate file 

Recent File List Quickly open one of the last few Navigation Objects files that were used. 

Exit Exits Coastal Explorer 

The Edit Menu 

Undo Undoes the last editing operation 

Redo Redoes the last editing operation that was undone 

Cut Cuts the selected objects to the clipboard 

Copy Copies the selected objects to the clipboard 

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/FileNew.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/FileOpen.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/FileSaving.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/FileSaving.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Printing.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Printing.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Printing.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/SendTo.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_Import.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_Export.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/FileOpen.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Clipboard.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Clipboard.htm


 

Coastal Explorer Reference  9 

Paste Pastes objects from the clipboard into the current Navigation Object File 

Delete Deletes the selected objects 

Select All Selects all of your navigation objects 

Find... Find a place by name or latitude/longitude 

The View Menu 

Quilting Enables or disables chart quilting. 

Scale Displays a sub-menu with several common chart scales to select from. 

Orientation Select the chart's orientation. 

Task Pane Turns the Task Pane on or off. 

Status Bar Turns the Status Bar on or off. 

Chart Outlines Turns the display of chart outlines on or off. 

Distance Scale Turns the display of the distance scale on or off. 

Browser Panel Displays a sub-menu with different Browser Panel types to select from. 

Full Screen Turns full-screen mode on or off. 

Properties Shows the properties of the selection in the Task Pane. 

The Insert Menu 

Route Starts adding a new route. 

Mark Creates a mark at the next place you click on the chart. 

Annotation Creates an annotation at the next place you click on the chart. 

Event Creates an event mark at the current boat location. 

Boundary Circle Creates a boundary circle mark at the next place you click on the chart. 

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Clipboard.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/FindingPlaces.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Quilting.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/ScrollZoom.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Rotation.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/CreateRoute.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/UsingMarks.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/UsingMarks.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/UsingMarks.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/UsingBoundaries.htm
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Boundary Area Starts adding a new boundary area. 

Range/Bearing Line Starts adding a new Range/Bearing line. 

Range/Bearing Line From 
Boat 

Adds a new Range/Bearing line from the boat to the next place you click on the 
chart. 

Instant Route Adds and activates a new route from the current boat position to the next place 
you click on the chart. 

Navigation Object File...  Imports navigation objects from a file into the current document. 

The Format Menu 

Base Object Display Selects a minimum amount of vector chart detail. 

Standard Object Display Selects a normal amount of vector chart detail. 

Full Object Display Selects a high amount of vector chart detail. 

Vector Charts... Adjusts vector chart formatting options. 

Text Size Selects the size of text shown on the chart. 

Chart Types Controls which types of charts are shown. 

Chart Colors Select the colors to use for drawing charts. 

Tide Levels Controls the display of tide level predictions on the chart. 

Tidal Currents Controls the display of tidal current predictions on the chart. 

Raster Chart Note Links Controls whether raster chart note icons appear on the chart (when available). 

Maptech Marine 
Facilities 

Controls whether Maptech Marine Facilities icons appear on the chart (when 
available). 

Maptech Aerial Pictures Controls whether Maptech Aerial Picture arrows appear on the chart (when 
available). 

Maptech Special Marks Controls whether Maptech Special Marks appear on the chart (when available). 

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/UsingBoundaries.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/UsingRBLs.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/UsingRBLs.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/UsingRBLs.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/CreateRoute.htm#instant
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Importing.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Tides.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Tides.htm
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The Tools Menu 
Chart Portfolio Hides or shows the Chart Portfolio. 

Navigation Object Browser Hides or shows the Navigation Object Browser. 

Weather Hides or shows the Weather Browser and chart layer. 

Activate Route... Select a route to activate. 

Deactivate Route Deactivates the active route. 

Enable Tracking Turns tracking on or off. 

Start New Track Starts recording another track. 

Cruise Mode Starts Cruise Mode. 

Download Charts... Download charts from the Internet (requires an Internet connection). 

Customize Customize the Coastal Explorer screen layout, instrument panels, and modes. 

Options... Provides access to program options. 

The Help Menu 

Contents and Index Displays Help 

Keyboard Shortcuts Displays all of the keyboard shortcuts 

Coastal Explorer Network Displays the Coastal Explorer Network web site 

Check for Updates... Checks the coastalexplorer.net website for Coastal Explorer updates 

Send Feedback... Sends e-mail to Rose Point Navigation Systems 

About Coastal Explorer Displays Coastal Explorer version information. 

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/ChartPortfolio.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/NavObjBrowser.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Weather.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/NavigateRoute.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Tracking.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Tracking.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/CruiseMode.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_Customize.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Options.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Default.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Keyboard.htm
http://coastalexplorer.net/
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_Update.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_SendFeedback.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_About.htm
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The Main Toolbar 

The toolbar normally appears near the top of the Coastal Explorer window just like in any other Windows 
program. However, in Cruise Mode and Full Screen Mode, the menubar and standard toolbars are not displayed. 
When using these modes, you can make the toolbars appear temporarily by moving your mouse cursor to the 
top of the screen. 

The Back button will take you back to places on the chart that you were recently looking at. The Forward button 
takes you back to places you were looking at before using the Back button. These buttons work together in the 
same way that the Back and Forward buttons on a typical web browser work. You can also use the Alt+Left 
Arrow and Alt+Right Arrow keys. 

Find Control This lets you easily find places by entering their name and clicking the GO button or pressing Enter.  

Zoom Control Use the magnifying glass buttons to zoom in or out, or use the slider to get the scale you want.  

Select Tool, Zoom Tool, and Pan Tool These buttons select between the three different mouse modes for 
selecting, zooming, and panning. The mouse mode determines what will happen when you press the left mouse 
button on the chart and drag the mouse. The Select Tool lets you select an area, which you can then Zoom To, 
Copy, or delete the objects within. The Zoom Tool just zooms to the area you drag across as soon as you let go of 
the mouse button. The Pan Tool lets you drag the chart around with the mouse. 

While you might be more familiar with the Zoom Tool if you have used other navigation programs, the Select 
Tool is very versatile as it allows you to pan by clicking near the edges of the chart, zoom by selecting an area 
and then clicking inside of it, or select multiple navigation objects in order to perform some operation on all of 
them. 

Chart Window and Split Chart Window These buttons let you decide if you want to see one large chart view, or 
two smaller chart views side-by-side. 

Chart Type Control This lets you control what type or types of charts appear.  
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The Navigation Object Toolbar 

The toolbar normally appears near the top of the Coastal Explorer window just like in any other Windows 
program. However, in Cruise Mode and Full Screen Mode, the menubar and standard toolbars are not displayed. 
When using these modes, you can make the toolbars appear temporarily by moving your mouse cursor to the 
top of the screen. 

Undo Undo the last editing operation. Redo Redo the last undone operation. 

Highlight Objects Washes out the chart image so you can see your Navigation Objects more clearly 

Add Route Starts adding a route. After clicking this button, click on the chart at each place you would like a 
waypoint. When you are done, click the last waypoint again.  

Add Mark Adds a Mark at the next place you click on the chart. 

Add Boundary Circle Adds a Boundary Circle at the next place you click on the chart. 

Add Boundary Area Starts adding a Boundary Area. After clicking this button, click on the chart at each place 
you would like to start a new side for the area. When you are done, click the last place again. 

Add RBL (Range/Bearing Line) Adds a Range/Bearing Line between the next two places you click on the chart. 

Go To Boat Pans the chart (if necessary) to ensure your boat's symbol is on the screen and resumes the last 
automatic scrolling mode you were using. Consecutive presses will change the current automatic scrolling mode 
between Follow Boat and Look Ahead. You can also press the Home key for the Go To Boat function. 

Browser Panel Displays a menu of different Browser Panels to choose from and an option to close the Browser 
Panel. 
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The Status Bar 

REVIEW: Need a picture! 

The status bar normally appears at the very bottom of the Coastal Explorer window when in Planning Mode, but 
can be turned on and off in any mode by using the View > Status Bar command.  

The status bar displays this information: 

 A message. When you are using the menus or hover the mouse pointer over a toolbar button, this area 
will display a short description of the selected command. If you hover the mouse over the chart, it will 
display the name of the nearest place in the gazetteer. Sometimes Coastal Explorer will place other 
messages here too, in which case it will make a ding to alert you that there is a new message.  

 The latitude and longitude at the mouse cursor.  

 If the boat position is known, the range and bearing from the boat to the mouse cursor  

 The depth range or units at the mouse cursor. When the information is available (from a vector chart), 
the range of depths in the area the cursor is pointing is shown. Otherwise the units of measurement for 
depth values is shown (depths on raster charts cannot be changed to match your preference).  

 The status of the GPS signal. This will indicate whether Coastal Explorer is in Dead Reckoning mode, has 
not yet received anything from a GPS (NO GPS), or that you have a GPS or DGPS fix, or that the GPS 
signal has been lost (LOST GPS).  
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The Task Pane 

REVIEW: Need a picture that shows the tabs and a scrolling arrow! 

The Task Pane typically shows properties for the selected chart or Navigation Object, but can also display search 
results, nearby places, virtual instruments, and other information.  

The Task Pane can be hidden or shown with the View > Task Pane option or by pressing the Ctrl+F1 key.  

The right side of Coastal Explorer window shows a list of available Task Panes and you can select a Task Pane to 
use by clicking on its name in this list. You can hide the Task Pane by clicking on the name of the Task Pane that 
is already shown.  

If the Coastal Explorer window is not tall enough for the list of Task Panes, you can scroll the list by dragging it 
with your mouse, or clicking on the arrow buttons that will appear at the top and/or bottom of the list when 
scrolling might be necessary.  

The Chart Overview 

 

The Chart Overview appears in the top part of the Task Pane while in Planning Mode and is an optional panel 
while in Cruise Mode. 

The Chart Overview shows an overview of what the primary chart viewing area is showing. The Chart Overview 
is always oriented North Up. 

Inside the Chart Overview is a rectangle that outlines the actual area displayed in the primary chart viewing 
area. One side of this rectangle has a dot on it to indicate which side is up in the chart viewing area. 

The rectangle may be dragged around with the mouse to scroll the primary chart. 

Double-clicking in the rectangle will zoom in and double-clicking outside the rectangle will zoom out. 

If you have a scroll wheel on your mouse, using it while pointing at the Chart Overview will change the scale of 
the primary chart viewer. 

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/TaskPane.htm
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Property Panels 

REVIEW: Need a picture showing tabs. 

Property Panels are a type of Task Pane that are used extensively in Coastal Explorer. Just about anything you 
click on in the Chart Area will cause details about that object to appear in the property panel.  

However, the Property Panel is not always visible. If you need information about an object or chart feature and 
the Property Panel is not visible, you can click the right-mouse button on the object or chart feature and select 
the Properties option from the menu that appears. The Alt+Enter key will also cause the Property Panel to 
appear.  

Most objects have more than one page of properties causing multiple tabs to appear in the property panel. Click 
on the tabs to see the different pages of properties. You can also use the Ctrl+Page Up and Ctrl+Page Down keys 
to switch between pages.  

Clicking on Vector Charts will usually cause two tabs to appear, one has information about the Chart in general 
while the other lists all of the objects that are at or very near the location in the chart that you clicked.  

Clicking on a Navigation Object will show all the properties of that object and allow you to adjust most of them.  
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Using the Browser 

REVIEW: Need a picture of a browser that has tabs and buttons on the title bar! 

The Browser integrates the Navigation Object Browser, Voyage Plan, Guide Book, Tide and Current Graphs, and 
some of the weather related features into a unified information panel that appears below the chart. When it is 
open, you can click on things on the chart to change what is shown in the browser. 

You can show the browser with the Browser Panel button on the toolbar, the View > Browser Panel menu, 
several commands on the Tools menu, or by right-clicking on the chart and selecting one of the commands 
between Guide Book and Weather. Once the panel is open you can use any of those commands to change the 
type of thing the browser is showing (tides, currents, weather, etc.). You can also click on the title of the browser 
to quickly get to the list of different page types you can choose from. 

When a browser is open, an extra layer of symbols may appear on the chart. Clicking on any of these symbols 
will cause the browser to show information for that symbol. For example, when the Guide Book Browser is 
open, symbols indicating the positions of other guide book entries will appear on the chart and clicking on those 
symbols will show those entries in the browser. 
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About Virtual Time 

Coastal Explorer lets you see tide level and tidal current predictions and weather forecasts for times other than 
"right now" by using a concept of "virtual time."  

Normally the virtual time is the same as the current "real time" and as the real time changes, so does the virtual 
time. However, when you use any of the "time changing" functions described below, the virtual time is set to 
the time you select and is paused so as not to advance with the real time.  

The time changing functions are found in the Browser toolbars for Graphical Weather Forecasts, Tide Level 
Predictions, and Tidal Current Predictions. Each of these has five buttons that let you move forwards and 
backwards in time by one hour or one day and to resume real time. You can hold down the forward and 
backward buttons to move by several hours or several days. 

In Planning Mode, whenever a virtual time is in effect the Virtual Time panel will appear in the lower-right 
corner of the primary chart panel to let you know what that virtual time is. You can always go back to "real time" 
by clicking on this panel. 

 

In Cruise Mode, the clock display in the top-right corner of the screen shows the Virtual Time. When the Virtual 
Time is different than the Real Time, a yellow warning bar pulses above the clock. You can click on the clock to 
see a menu of time-related options, including the ability to return to Real Time. REVIEW: Need a picture of this! 
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Printing 

REVIEW: This needs to talk about printing tide and current predictions! 

Coastal Explorer can print charts, tide level and tidal current predictions, and route details. When the Route 
Details panel is open and you use the print feature, the page will include a chart in the top half and the details of 
each leg of the route in the bottom half. When the Route Details panel is not open, the chart will cover the 
entire page. 

Printed charts have the same level of detail and other formatting options as the displayed chart, so you should 
get the screen to look the way you want your page to look before starting to print. 

When you are just printing a chart, the page will contain the same area that is on the screen plus an additional 
area needed to fill out the page. If you are printing in portrait mode (a vertically oriented page), then the middle 
of the page will probably contain the same as what you see on the screen and additional area will be charted at 
the top and bottom of the page. 

When you use File > Print Preview before printing, you can see exactly what will appear on the page and even 
"nudge" the chart around and zoom in/out to get it just right. 

When you are printing a chart with route details, the area of the chart that is printed is always the area covered 
by the route. In this case, you cannot fine-tune the chart placement in Print Preview mode. 

The File > Page Setup command will let you adjust the page size and orientation, paper source, and margins for 
your pages. 
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Introduction to Cruise Mode 

The standard Windows interface works great when you are sitting at the computer using your mouse and 
keyboard and are focused on the task of planning your trip. However, when you are cruising and you are focused 
on the water ahead of you and the hazards and other boats in the area, menus and toolbar buttons become 
much more difficult to use! This is the problem that Cruise Mode solves. 

In Cruise Mode, Coastal Explorer takes over the entire screen and hides the standard menu and toolbars. In 
order to provide easy access to the commands you’ll need while underway a few large, easy to press buttons 
appear at the top and bottom of the screen. 

Cruise Mode starts automatically when your boat starts moving one knot or faster. It may be entered at any 
time by using the Tools > Cruise Mode command or by pressing the F12 key. You can get back to Planning Mode 
with the Planning Mode command on the main menu or by pressing the F12 key again.  

Here is a typical Cruise Mode screen: 

 

As you can see, Coastal Explorer does not look like your typical Windows application in this mode.  

Across the top of the screen is a bar that contains various controls and indicators including:  

Program and Mode identification -- click here to select a different Mode (e.g. Plan Mode, Cruise Mode, etc.), 
use any of the Browser Panels, open the Options window, or exit Coastal Explorer. See Main Menu below. 

Reset -- Clicking this button will reset your display to some pre-determined settings. This is useful when you've 
been scrolling around, rotating the chart, zooming out, and splitting the window and just want to get back to the 
"normal" view around your boat. You can control what settings will be selected when you click this button.  

MOB -- Clicking this button will start Man Overboard mode.  

Event -- Clicking this button will insert an Event Mark at the current location of your vessel.  

GPS Status -- This provides an indication of the strength and accuracy of your GPS signal. If you have more than 
one position source, you can click here to see a list of vessel position sources available and select a different one 
to use. You can also click here to turn tracking on or off and to set other tracking options.  
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Battery Status -- If your computer is running on batteries, and your batteries are getting low, you will see an 
indication of the battery level and an estimate of how much time you have before the computer needs to shut 
down.  

Date and Time -- The current Real or Virtual Time is displayed. You can click here to select from the available 
time formats and to select between daylight, dusk, and night modes.  

Cursor Information -- Across the bottom of the toolbar, you'll see the name of the place the cursor is pointing at 
as well as the lat/lon of the cursor and the range/bearing from your boat to the cursor.  

If you have a Rose Point Radar these controls will also appear on the toolbar: 

Radar Transmit/Standby -- This will let you turn the radar transmitter on or place the radar in standby.  

Radar Controls -- This will appear when the radar is transmitting and show you the current settings. Clicking on 
this control will change the toolbar to show more radar controls such as Gain, Sea Clutter, and Rain Clutter.  

Main Menu 

Clicking on the Coastal Explorer logo causes the Main Menu to appear: 

 

The Main Menu provides the following options: 

Search Start typing to search for a place. The search results will appear below the search box as you 
type. You can press Enter when you are done, click on one of the results to go there, or press 
Esc to cancel. 

Modes The operation modes appear next; clicking on one activates that mode. 

Screens Your custom screen layouts appear as small screen shots (or a box with an X if you haven’t 
customized a screen yet). Click on a screen to activate it. Press and Hold on a screen to quickly 
save the current layout to that custom screen. 

Browsers A list of the Browser Panels starts the second column of the Main Menu. Click on one to open 
the Browser. 
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Customize Starts Customize mode where you can create new screen layouts, instrument panel pages, and 
even operation modes. 

Options Opens the Options window (this is the same as Tools > Options) 

Exit Exit Coastal Explorer (this is the same as File > Exit) 

Chart Viewer Toolbar 
At the bottom of a chart viewer, you'll see a toolbar with these buttons:  

Orientation -- Click this to cycle through North Up, Heading Up, and Course Up  

Follow Mode -- Click this to cycle through Don't Follow, Center on Boat, and Look Ahead modes  

Scale -- Click on the + or - buttons to zoom in or out, or click in between them to see a menu of scales to choose 
from  

Information -- Click this to see a menu of options that affect how the chart and other data is displayed. (See 
below.)  

Add -- Click this to see a menu of Navigation Objects that can be added  

Chart Information Menu 

The Chart Information Menu provides several pages of options that control types of charts to display and how to 
display them. 

 

The first column is a list of pages; click on an item in the first column and the second column will display that 
page of options. 

Chart Colors Use this to control which color set to use in Daylight Mode (Dusk and Night modes each only 
have one color set that can be used. This page is also where you’ll find the handy Highlight 
Objects command. 

Chart Types Use this to control the type or types of charts you want to see. 

Vector Options This page provides access to vector chart specific options. 

Raster Options This page provides access to raster chart specific options. 

Extra Layers This page lets you turn on and off the display of various layers such as the Distance Scale 
and Chart Outlines.  
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Radar Use this page to turn the display of radar tools such as Electronic Bearing Lines, Variable 
Range Markers, and Range Rings on or off. 



 

24 

Custom Screen Configurations 

Coastal Explorer lets you save and restore custom screen configurations from the Main Menu in Cruise Mode. 

Six separate screen configuration "slots" are available. These screen slots appear on the Cruise Mode Main 
Menu under the Find Box and each one can hold a configuration of one to four views including their relative 
sizes and their settings. 

More specifically, each screen configuration consists of one to four views, where each view consists of a type 
and settings appropriate to that type of view. Chart views keep track of the latitude and longitude at the center 
of the view, the chart viewing scale, what types of charts are shown (raster, vector, topo map, etc.), the chart 
orientation, and the auto-scrolling mode. Video views keep track of which video source is being used. Radar 
views keep track of the off-center location and the status of tools such as VRM's and EBL's. In addition to these 
view settings, the screen configuration keeps track of the relative sizes of the views. 

You can use saved screen configurations to quickly reconfigure Coastal Explorer for specific tasks. For example, 
you might normally cruise with a large chart view at a large scale in look-ahead mode alongside a smaller chart 
view at a small scale in center-boat boat. Then, when docking, you might prefer to have one large scale chart 
and a couple of video views. If you have a Coastal Explorer Radar, you might want a small radar-only view and a 
small overview chart as well as a large chart. 

To create screen configuration: 
 Use the 1, 2, 3, or 4 keys to split the screen into that many separate views 

 Right-click on views that you want to change the type of. The context menu that appears will contain a 
list of available view types (Chart, Video, or Radar (if installed)).  

 Adjust the relative sizes of the views by dragging the "splitters" (the spaces between the views). 

 Adjust the settings of the views (such as follow-modes, scale, orientation, etc). 

 Save the configuration by clicking on the Main Menu and then pressing and holding the mouse button 
on any of the screen slots on the left side of the menu. Hold the button for two seconds and you will 
hear a beep and see the slot symbol change to a screen shot of your configuration. 

To load a screen configuration: 
 You can quickly load a screen configuration by clicking on its screen-shot in the Main Menu. 

After selecting a screen, you can make adjustments to the views if you want. However, any adjustments are not 
automatically saved if you select a different screen or exit Coastal Explorer. If you do want to save changes, just 
open the Main Menu and press and hold the left mouse button on the screen slot you want to save to. 
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Charts 
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Chart Compatibility 

Coastal Explorer utilizes various formats of charts from several manufacturers. Each type of chart has its own 
advantages and disadvantages, and many of these are subject to your individual tastes.  

Raster Charts 
Raster charts are simply digital pictures of paper charts that also contain the information necessary to convert 
between locations in the picture and a latitude and longitude. Most raster charts also contain other information 
such as when the last update was made and the units of depths. 

Some people prefer raster charts over the newer vector charts because they seem more familiar - they are just 
copies of paper charts after all. As you'll see later, though, vector charts have some major advantages over 
raster charts and will soon be the world-wide standard chart format. 

Two major formats of raster charts are available: the so called "Maptech/BSB" format and the "SoftChart 
NOS/GEO" format. Both formats have a lot in common, but are different in the details. In both cases, a "chart" is 
made up of two or more files. One of these files is relatively small and has a file type of .BSB or .GEO. The other 
file (or files) contain the image of the chart and can be very large. These files have a type of .KAP or .NOS. Some 
charts, especially small-craft charts from Maptech will have more than one image file; one for each page, panel, 
or inset from the original chart.  

Coastal Explorer is fully compatible with the Maptech/BSB4 and Maptech/BSB5 format charts which add copy 
protection to the basic BSB format. In order to use these charts with Coastal Explorer you must first use the 
setup program included with the charts to register them for use on your computer. 

Nautical Data International, Inc. (NDI) is a distributor for Canadian raster charts which are sold under the brand 
name of "Digital Ocean." These charts are in the Maptech/BSB4 format and work fine in Coastal Explorer. 

The older "PCX Format" and "RML Format" charts are also fully compatible. These formats are still used by 
several producers of digital charts covering areas outside of the United States. Be aware, however, that charts in 
this format tend to be pretty out of date. 

Photo Charts 
Photo charts are a variation of raster charts. They are still a static picture, but rather than being a picture of a 
chart, they are a photograph of an area. Photo charts are especially handy for checking out shallow areas as they 
clearly indicate the location of shoals and channels. 

Photo charts are usually derived from the Digital Orthogrpaphic Quadrangle (DOQ) photos created by the USGS. 
The originals are available in various forms on the Internet and Coastal Explorer can use the GeoTIFF format. The 
USGS does not offer the DOQs for download, but many states have universities that do.  

Maptech's "Navigation Photos" and SoftChart's "PhotoNavigator" charts which are derived from the USGS DOQs 
are also supported. 

Vector Charts 
Rather than storing the entire chart as a single image like a raster chart, vector charts are made up of many 
separate "objects" such as coastlines, bays, land areas, buoys, and depths. Some of the advantages of this 
method include: 
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 The display of individual types of objects can be controlled which allows you to control clutter on the 
screen  

 The units of displayed measurements can be controlled  
 The database of object descriptions uses much less storage space than an equivalent raster chart  

 There is a greater amount of information stored in the database that computer software can take 
advantage of for advanced features such as route safety checking.  

 There are really only three disadvantages to vector charts: 

 Coverage of vector charts is not as complete as raster charts (yet)  
 Many vector charts do not have as much detail as their paper counterparts  

 The resulting display does not look as familiar as a paper chart  

Vector charts are available in many different formats, including various types from C-MAP and Navionics, 
Passport from Nobeltec, BlueChart from Garmin, and many others. Coastal Explorer does not support any of 
these proprietary formats. 

REVIEW: Make a note about Navionics charts? 

The only non-proprietary vector chart format is called S-57, or ENC (short for Electronic Navigation Chart), and is 
the standard format used by just about every hydrographic office in the world for official government charts. S-
57 ENCs are the only vector chart format approved for use as paper chart replacements on SOLAS (Safety Of Life 
At Sea) class vessels such as cargo and cruise ships. 

One of the most surprising features of S-57 ENCs is that NOAA and the U.S. Army Corps of Engineers has decided 
to give them away for free! They are busy converting their paper charts into this format and are making them 
available on the Internet at the addresses listed below. At the time of this writing over 300 ENCs are available 
from NOAA and about 40 from the USACE.  

Canadian ENCs may be purchased from Nautical Data International, Inc. under the brand names of "Digital 
Ocean Recreational Vector" or "Digital Ocean Professional." Many other countries make ENCs available through 
their hydrographic office or its distributor. 

ENCs are made up of one or more files, usually stored in a folder that just contains files related to one chart. The 
most important file has a type of .000 which contains the chart database. Other files with the same name but 
different numeric file types (such as .001, .002, .003, etc.) may be in the chart's folder and contain updates to 
the database. Any number of other files, usually text or TIFF images, may be in the folder and contain extra 
information or pictures that are referenced by the database. 

S-57 refers to the world-wide standard format of a vector chart database. Another world-wide standard, called 
S-52, refers to the way to present that database to a user in a graphical way. S-52 determines colors, line-styles, 
fill-patterns, text placement, and all of the other details that go into drawing a chart database on a computer 
screen. Coastal Explorer has complete support for S-57 ENCs drawn according to the S-52 specification.  

Coastal Explorer includes vector charts for most of the United States. These charts are proprietary to Coastal 
Explorer but are made from the "Digital Nautical Charts" (DNC®) produced by the National Geospatial-
Intelligence Agency (NGA). The Coastal Explorer Charts look and work much like the ENC, but are a completely 
different format of chart and you will notice some differences. Since the NOAA ENC is the "official" electronic 
chart of the United States, they will usually appear on top of a Coastal Explorer Chart when you have the same 
chart in both formats. 
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Topographic Maps 
Topographic maps are not suitable for navigation, but are very handy for hiking around that island you just 
anchored near! Coastal Explorer can use the topographic maps that are included in most Maptech ChartKits as 
well as the original USGS DRG files which are found in the GeoTIFF format. See also: Using Topographic Maps. 

Electronic Chart Manufacturers 
These are just some of the chart manufacturers that create Coastal Explorer compatible charts: 

NOAA ENC® These vector charts are available for free and cover much of the US coast.  
 
NOAA RNC™ These raster charts are available for free and cover the entire US coast as well as some lakes.  

U.S. Army Corps of Engineers Inland ENC These vector charts are available for free and cover major U.S. rivers.  

Maptech Digital Charts Maptech distributes raster charts for most of the world. Maptech's Digital ChartKits 
usually contain a marine facilities directory and aerial photos for the region and this information is used by 
Coastal Explorer as well as the charts and maps.  

Canadian Hydrographic Service produces the official charts for Canadian waters. Both raster and vector charts 
are available from CHS chart dealers.  

U.S. Geological Survey The USGS produces "DRG" topographic maps as well as "DOQ" photo charts the the 
GeoTIFF format which may be used with Coastal Explorer.  

 

http://chartmaker.ncd.noaa.gov/mcd/enc/download.htm
http://nauticalcharts.noaa.gov/mcd/Raster/download.htm
http://www.tec.army.mil/echarts/
http://www.maptech.com/
http://www.charts.gc.ca/pub/en/digitalchart/default.asp
http://www.usgs.gov/
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Chart Portfolio 

REVIEW: Need a screen shot of the Chart Portfolio! 

The Chart Portfolio is yet another mode focused on a particular activity which, in this case, is managing your 
chart collection. 

You can get to the Chart Portfolio with the Tools > Chart Portfolio command. You can get back out with the 
same command or with the Close command on the Chart Portfolio’s toolbar. 

The Chart Portfolio shows you all of the charts on a particular hard drive, CD-ROM drive, removable storage 
device, or the combination of all of your hard drives if you have more than one. You can select which collection 
you want to see with a drive list on the toolbar. 

You can also decide whether you want to see all chart types or only a particular type of chart. This works just it 
does in Planning Mode; just use the Chart Type selection tool. 

The Chart Portfolio window displays collections of charts in several ways: 

The Details view shows the name, number, scale, and type of each chart in the collection. 

The Thumbnails view shows a small image and the name of each chart in the collection. 

The World Map view shows a map of the world superimposed with the outline of each chart in the collection. 
Clicking within an outline will select a chart. When multiple charts overlap you may need to right-click which will 
show you a list of charts to select from. 

You can select which view to use by selecting it from the toolbar, the View menu or the right-click menu. 

The charts may be sorted in each of the views by selecting one of the Arrange By options on the View menu or 
the right-click menu. 

When a chart is selected, the property panel shows an overview of the chart and just about all of the 
information that can be found in the chart file such as the name, original scale, the producing agency, and the 
date of the last update made. 

In any of the different views, you can open a chart, print a chart, or copy a chart to a different disk drive by 
selecting it and using the menus, toolbar, or keyboard. Holding down the Ctrl key when selecting a chart allows 
you to select more than one chart at a time, and all of the actions will work with multiple charts. 

To Open selected charts, you can: 
 double click on a selected chart  

 press Enter  

 or, right-click on a selected chart and select Open  

To Print selected charts, you can: 
 use the Print button on the toolbar  

 use the Print... command on the File menu  

 or, right-click on a selected chart and select Print...  

To Copy selected charts, you can: 
 use the Copy Charts button on the toolbar  

 or, right-click on a selected chart and select Copy to...  
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A chart collection refers to all of the charts on a hard drive, CD-ROM, or USB Flash Drive. The Chart Portfolio 
window has a list of collections to choose from at the top of the window. 

When a CD-ROM containing charts is inserted into a CD-ROM drive, that collection is automatically selected. If 
the CD-ROM contains charts that are not also on a hard drive, you will be asked if those charts should be copied 
to the hard-drive. Copying charts to a hard drive can significantly speed up the display of those charts. 
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Installing Charts 

Coastal Explorer can use electronic charts from several different manufacturers and will automatically search for 
chart files in a few standard folders on your computer.  

If you have compatible charts on your computer, but Coastal Explorer does not seem to know about them, you 
can easily tell it where they are or have it search your entire computer. 

Some charts you buy may require you to use the manufacturer's installation procedure, but others can be 
installed by Coastal Explorer. If you insert a disk containing charts while Coastal Explorer is running, and it can 
handle installing those charts, it will provide you with on-screen instructions. 

Coastal Explorer also has the ability to extract chart files from ZIP files which are a common way of combining 
multiple files together and compressing them in order to use less disk space and download from the Internet 
faster and easier. 

To change where Coastal Explorer looks for charts: 
 Select the Options command from the Tools menu  

 Click on the Charts tab.  

 Click the Chart Folders... button. 

 Follow the directions in the window to change the folders that will be searched for charts.  

To install charts from a CD or DVD: 
 While Coastal Explorer is running, insert the CD/DVD into your computer's CD/DVD-ROM drive.  

 Coastal Explorer should notice the new CD/DVD, scan it for charts, and guide you through the 
installation process.  

 If this does not work, you may need to follow any directions provided by the chart manufacturer.  

Some chart manufacturers apply copy protection to their charts which must then be activated before they can 
be used. If you have copy protected charts, please follow the registration or activation instructions that came 
with them before trying to use the charts with Coastal Explorer. 

To install vector charts from the Internet: 
 Use the Tools > Download Charts command and follow the displayed instructions  

To install charts from a ZIP file: 
 Use File > Open to find and open the ZIP file, or  

 Drag the ZIP file from a folder window to the Coastal Explorer window. 
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Chart Options 

Tools > Options > Charts 

This page of the options window provides access to various options regarding where Coastal Explorer should 
look for charts on your computer, which of them it should include in the chart quilt, and where it should install 
new charts. 

Chart Folders This provides access to a list of folders that Coastal Explorer will search for charts in. 

Automatically install charts when a new CD is inserted This option causes Coastal Explorer to search CDs that 
are inserted into a CD-drive for charts. If a CD is found to have charts that are not on any hard-drive, you will be 
given the option of installing them. When this option is turned off, you will need to use the Install Charts button 
on this option page to install the charts manually. 

Install Charts Provides tools for installing or updating charts to a hard-drive from a CD or other source. You can 
also get to the Install Charts tools with a button on the toolbar in the Chart Portfolio. 

Chart Portfolio This provides a quick way to get to the Chart Portfolio window where you can adjust which 
charts should be included in the quilt among other things. 

ChartKit Folder This tells Coastal Explorer where to install and find non-chart data included with Maptech 
ChartKit products including Marine Facilities and Special Marks. This is normally "C:\CHARTKIT". 

Contour 3D Folder This tells Coastal Explorer where to install and find Maptech Contour 3D data. The default 
location is "C:\3DCHARTS". This option only appears when the Maptech Contour 3D option has been installed. 
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Chart Folders Window 

Tools > Options > Charts > Chart Folders 

 

This window lets you choose the folders that Coastal Explorer will search for charts. 

You can get to this window with the Tools > Options > Charts > Chart Folders command or from the Install 
Charts window. 

Each time Coastal Explorer is started it will scan for changes in chart folders. You can install new chart files, un-
install chart files, or update your chart files while Coastal Explorer is not running using your chart manufacturer's 
setup programs or with Windows and your chart portfolio will be updated the next time Coastal Explorer is 
started. 

Coastal Explorer automatically scans several folders where charts are frequently found. If you have chart files in 
other folders, use this window to add those folders to the list. You can also have Coastal Explorer scan your 
entire computer for chart files and fill in the list for you. 

This window displays a list of all of the folders that will be scanned by Coastal Explorer. In this list, some folders 
specify which drive they are on (such as "C:\Charts") and some do not specify a drive (such as "\Charts"). When a 
drive letter and colon are used, only the folder on that drive is included, but when the drive letter and colon are 
omitted, Coastal Explorer will search the folder on all drives on the computer (including hard drives and CD-ROM 
drives).  

To add a folder to the list: 
1. Click the Add... button.  
2. Enter the name of the folder and click OK  

To remove a folder from the list: 
1. Select the folder you want to remove  
2. Click the Remove button  

To have Coastal Explorer scan your computer for charts: 
1. Click the Full Scan button  
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Add Chart Folder Window 
Tools > Options > Charts > Chart Folders > Add Chart Folder 

 

This window is used to add a folder to list of folders that Coastal Explorer monitors for charts. 

Enter the full path of the folder you want to add, or use the Browse button to look for the folder. 

You can tell Coastal Explorer to monitor the same folder on all drives by leaving off the drive letter. For example, 
entering "\Charts" will cause Coastal Explorer to monitor C:\Charts, D:\Charts, E:\Charts, etc. 
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Install Charts Window 

Tools > Options > Charts > Install Charts 

REVIEW: Need a picture of this window! 

This window lets you choose which charts to install from a CD-ROM or other chart volume. 

This window will appear when you have inserted a CD-ROM containing new charts and choose to install them in 
order to improve performance. You can also get to this window manually with the Tools > Options > Charts > 
Install Charts command or the Install Charts button on the Chart Portfolio's toolbar. 

Charts are installed in different folders based on the type of chart. You can change the folder for each type of 
chart by pressing the Change Chart Installation Folders button. 

To Install Charts from a CD-ROM or other Removable Storage Device 
1. Select the CD-ROM drive that has the charts on it with the Look In list.  
2. Check off the charts that you want to install. (The list will start out with all of the charts that are not 

currently on a hard drive checked.)  
3. Press the Install button.  

To Install Charts that are on a Hard Drive 
Coastal Explorer considers every chart that is on a hard drive to already be installed, however it may need to be 
told where to find them. 

 Select the hard drive that has the charts on it with the Look In list.  

 Click the Chart Folders button to change where Coastal Explorer looks for charts.  

 Refer to the Chart Folders help page for more steps...  

Chart Installation Folders Window 
Tools > Options > Charts > Install Charts > Change Chart Installation Folders 

 

This window lets you choose where Coastal Explorer will install charts on your computer. 

You can get to this window from the Install Charts window.  

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_ChartInstallFolders
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_ChartFolders.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_InstallCharts.htm
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Each type of chart may be installed in a different folder or you can use the same folder for different types of 
charts. When Coastal Explorer is installed, most chart types have a default installation folder that is the same as 
the chart manufacturer's recommended location. 

To change where Coastal Explorer will install a type of chart: 
2. Select the type of chart from the list  
3. Click the Change Folder button  
4. Enter a new folder for that type of chart, or use the Browse button to find the folder  
5. Click OK 
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Using Topographic Maps and GeoTIFF Files 

To use Coastal Topographic Maps from Maptech: 
 Install the topographic maps from the Maptech Digital ChartKit CD-ROM  

 Select Topo Maps from the Chart Type selection box on the toolbar  

To use USGS "DRG" topographic maps or other files in the GeoTIFF format: 
If you have the "metadata" files (.FGD files) that usually come with the USGS DRG topographic map files, then 
you can use the GeoTIFF files just like they were normal charts by telling Coastal Explorer where to find the files 
in the Tools > Options > Charts > Chart Folders window. 

If you do not have the corresponding metadata files, you must open the GeoTIFF files with the File > Open 
command. 

REVIEW: This should include information about GeoTIFF capabilities and limitations… 
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Instruments 
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Setting up Instruments 

Many electronic marine devices have a feature known as "NMEA 0183". This is an electrical interface that allows 
different pieces of equipment to share data with each other. This shared data is made up of "sentences" which 
essentially say things like "the GPS is at 47.123N 122.321W", "the depth is 23 meters", and "the boat is moving 
at 13 knots through water". 

Coastal Explorer can utilize information from many different instruments on your boat if they are connected to 
the PC through an NMEA 0183 interface. A GPS will be the most common type of instrument, but depth 
sounders, speed sensors, wind vanes, and even some RADAR units can supply useful information to Coastal 
Explorer.  

Coastal Explorer can also send information to NMEA 0183 compatible devices such as autopilots, data displays, 
and RADAR units. 

Coastal Explorer can also use the proprietary "Garmin" interface used by Garmin's very popular line of GPS 
receivers. 

NMEA Interfaces and Multiplexers 
In order for Coastal Explorer to take advantage of your NMEA 0183 compatible instruments, your PC must be 
connected to them. Two different kinds of devices are available that provide an interface between NMEA 0183 
and a PC's serial port (such as COM1 or COM2) or a USB port. 

One of these devices is usually called an "NMEA Adapter" and allows a single NMEA 0183 device (usually a GPS) 
to be connected to the PC. The other type is called an "NMEA Multiplexer" and allows more than one NMEA 
0183 device to be connected to a single serial port. The multiplexer is more complicated on the inside because it 
needs to merge the sentences from more than once source without mixing them up, but the way you hook them 
up is basically the same is an adapter. 

One issue that arises with NMEA Multiplexers is that they are usually receiving data at the same rate that they 
can transmit it, but they are receiving it from multiple sources. There is no problem when the data comes in as 
small bursts from each source, but when too much data starts to come in, some of it will be lost. Some 
multiplexers can be setup to transmit at a higher rate than the default. If you have one of these multiplexers, 
you can use the Advanced NMEA Port settings (see below) to configure Coastal Explorer to accept the higher 
rate of data. 

Some GPS devices have the ability to connect directly to a PC's serial port without the need for an adapter or 
multiplexer. 

Many modern PC’s no longer have COM ports built in, but one (or more) can be added using a PCI card that is 
installed to a desktop PC, a PC Card (PCMCIA) that is installed in a laptop, or a USB adapter that plugs into just 
about any PC. Any of these solutions will require a “driver” which is usually provided on a CD-ROM that comes 
with the adapter. Most manufacturers also provide updated drivers on their websites, and it is almost always 
better to be using the latest driver that was made for the version of Windows you are using! 

General Hardware Setup Steps 
Every piece of equipment is different, so you will have to consult your equipment's documentation to find out 
how to get it connected to your PC, but the general process is: 
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1. Wire it up - connect the output from the device to the input of an adaptor or multiplexer and connect 
the serial port of the adaptor or multiplexer to the serial port of the PC. Your adaptor or multiplexer 
should have come with instructions specific to its installation.  

2. Enable NMEA Output - some devices may need to have the output of NMEA sentences enabled; refer to 
the device's documentation.  

Configuring Coastal Explorer to Receive Instrument Data 
 Select the Options... command from the Tools menu.  

 Click on the Instruments tab.  

 Click the Auto Detect... button to have Coastal Explorer automatically find the right port and 
configuration, or  

 Click on the Port Settings... button if you would rather just select the right port and configuration.  

Configuring Coastal Explorer to Send NMEA 0183 Data 
 Select the Options... command from the Tools menu.  

 Click on the Instruments tab.  

 Click on the Autopilot... button.  

 Select your autopilot's manufacturer and model from the lists, or  

 Use the Options and Sentences tabs to select the right options for your autopilot (you may need to refer 
to your autopilot's manual).  

Troubleshooting 
Getting your boat to talk to your computer the first time can sometimes be a bit challenging. To help you with 
this task, Coastal Explorer has an Instrument Port Troubleshooter which will show you the NMEA 0183 data that 
is being receiving from your boat in a few different ways. 

To access the Instrument Port Troubleshooter  

 Select the Options... command from the Tools menu.  

 Click on the Instruments tab.  

 Click on the Troubleshooter... button. 

More information about using the Troubleshooter is provided below.  

 



 

42 

Instrument Options 

Tools > Options > Instruments 

This page of the options window lets you control how Coastal Explorer interacts with instruments connected to 
your computer. 

 Auto Detect This will search your computer's communication ports for one receiving NMEA 0183 data 
(from a GPS, for example) and set it up automatically.  

 Port Settings This will allow you to manually configure your NMEA 0183 communication port.  

 Troubleshooter This displays a diagnostic tool which will show you the NMEA 0183 data as it is received 
by your computer.  

 Data Logging This provides access to options for recording all incoming NMEA 0183 data.  

 Autopilot This provides access to all of the autopilot settings.  
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Automatic Port Detector Window 

Tools > Options > Instruments > Auto Detect 

 

This window may be used to have Coastal Explorer search for COM ports that are connected to compatible 
equipment (such as your GPS).  

While the window is displayed, Coastal Explorer will attempt to open all of the COM ports on your computer and 
wait for navigation data to appear. If all goes well, Coastal Explorer will tell you what port it found navigation 
data on and save the appropriate settings. 

While Coastal Explorer is scanning, you will see a list of the COM ports it found and the status of each port. 

COM ports can only be used by one program at a time, so if some other program is already using a COM port, 
Coastal Explorer will show its status as being in use by another program. If that is the port that you want to use, 
you will need to figure out which program is using it and make it release the port. A common culprit is the 
synchronization software for PDA's, so if you are running something like that, you might check its settings first. 

Using a Garmin GPS 
Many Garmin GPS products can transmit either NMEA 0183 or one of two proprietary protocols of their own. 
Coastal Explorer can only use the “NMEA 0183” and “Garmin” protocols, but it will detect the Garmin "Text Out" 
protocol and let you know if it is being received on a COM port. If this happens, you should use the menus on 
your GPS to select the NMEA 0183 or Garmin interface. 
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Instrument Port Settings Window 

Tools > Options > Instruments > Port Settings 

This window lets you specify the COM ports and COM port settings for your GPS or other instruments. Coastal 
Explorer can usually determine these settings for you with the Automatic Port Detection feature, but this 
window gives you complete control over the settings. 

 

To set up your GPS or other instruments: 

 Select a COM port from the list.  

 Select the appropriate Interface from the drop down list.  

 Select a baud rate if necessary.  

 Select the appropriate Listener, Talker, and Repeater options if necessary.  

The Interface option determines the "protocol" used for communications between the PC and the instruments 
on the port. This should usually be set to "NMEA 0183" but if you are using a Garmin GPS, you can select the 
"Garmin" interface. It is important that the GPS be configured to use the same interface as the one selected 
here. Check the documentation for your GPS to see how to select which interface it will use. 

The Baud Rate option determines the speed of communications between the PC and the instruments connected 
to the port. It is important that the speed selected here is the same as the speed selected on the instrument. 

The NMEA 0183 interface standard specifies that serial communications occur at 4800 baud. However, some 
NMEA 0183 PC interfaces may require different settings. Check the documentation that came with your 
interface for more information. 

Most AIS Receivers and Transponders use a high-speed version of NMEA-0183 which is called “NMEA-0183HS”. 
This is exactly the same as NMEA-0183 except that the baud rate is 38400 so if you are connecting an AIS device, 
that is probably what you need to select here. 

The Garmin interface standard specifies that serial communications occur at 9600 baud. However, some Garmin 
GPS receivers allow the baud rate to be adjusted so you might need to select a different baud rate here to match 
the setting in your Garmin GPS. 

The Listener, Talker, and Repeater options are for the NMEA 0183 interface only and determine how data sent 
to and received from the port. 

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_NMEA_AutoDetect.htm
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The Listener option indicates whether or not NMEA 0183 data should be received on the selected port. This 
option should be on for any ports that have instruments that send data such as your GPS receiver or depth 
sounder.  

The Talker option indicates whether or not NMEA 0183 data should be sent to the selected port by Coastal 
Explorer. This option should be on for any ports that have instruments that need to receive information such as 
your autopilot. 

The Repeater option indicates whether or not NMEA 0183 data that is received on any port should be repeated 
by sending it to the selected port. This is different from the Talker option which affects data that is generated by 
Coastal Explorer. Be very careful with this option as setting it on a 4800 baud port when you have several 
ports configured as Listeners is likely to cause the port to become “clogged” and not be able to handle all of 
the data being repeated. 

The Filter Sentences option is also for the NMEA 0183 interface only and may be used to cause some sentences 
to be ignored when they are received on a port configured as a Listener. (When sentences are filtered out, they 
are not sent to Repeater ports so this is a good way to reduce the chances of ports getting clogged.) For more 
information, see Filter Sentences Window below. 

Filter Sentences Window 
Tools > Options > Instruments > Port Settings > Filter Sentences 

 

This window lets you configure which NMEA 0183 sentences Coastal Explorer should use and which ones it 
should ignore. Normally all sentences are used, but you might need some to be ignored if: 

 you have a faulty piece of equipment that is sending erroneous data but other instruments are sending 
useful data to the same port  

 you are receiving redundant or unnecessary information on a port and need to reduce the amount of 
data that is being sent to repeater ports  

The Filter Sentences window contains a list of all standard NMEA 0183 sentences with a checkbox next to each 
one. Clearing a checkbox causes that sentence to be ignored. Each port has a separate list of filtered sentences. 

TIP: You can also use the Sentences page of the Port Troubleshooter to filter sentences. The Troubleshooter is 
the only way to filter out proprietary sentences and it also allows you to filter out sentences based on the type 
of instrument that is sending the information. 

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_NMEA_FilterSentences.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_NMEA_TestPort.htm
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Add Network Port 
Tools > Options > Instruments > Port Settings > Add Network Port 

 

You can also use virtual serial ports to send and receive NMEA 0183 data over a network if your network has a 
compatible server. To use this feature, click the Add Network Port... button and enter the network address of 
your server. Once a network port has been added, it may be configured just like a normal COM port, or you can 
delete it with the Delete button. Network ports don’t let you specify a baud rate because the data rate is based 
on the speed of your network.  

To configure a network port, use this window to enter the address of the data server. The address should consist 
of the network name of the server or the dotted IP address of the server (e.g. 192.168.0.12). The name or 
address may be followed by a colon and the network port number that should be used. 

Coastal Explorer uses a basic TCP/IP protocol similar to TelNet to send and receive NMEA 0183 sentences over 
the network. This protocol is compatible with many RS-232 to Ethernet Adapters, Internet-based AIS "feeds", 
and software packages that use, generate, or repeat NMEA 0183 information over networks. 

Coastal Explorer cannot, however, be configured to share data directly with another Coastal Explorer running on 
another computer; some sort of server is needed to facilitate this sort of configuration. 

 

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_NMEA_AddNetPort.htm
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Instrument Port Troubleshooter 

Tools > Options > Instruments > Troubleshooter 

REVIEW: Need screen shots! 

REVIEW: Need information on how to troubleshoot! 

The Instrument Port Troubleshooter was designed to help you track down problems with connecting your 
NMEA 0183 compatible equipment to your PC. It allows you to look at the data coming into your PC through a 
COM port in various ways and shows you the kind of instruments that your PC is receiving data from. 

To Use the Troubleshooter 
1. Select the port you want to troubleshoot from the drop-down list.  
2. Make sure the Listener option is checked if you want Coastal Explorer to "listen to" (receive) the data on 

that port.  
3. Use the General page to see errors and warnings that may be detected on the selected port, or a list of 

instrument types that are sending data to that port.  
4. Use the Sentences page to see a list of all of the NMEA 0183 "sentence" types that have been received 

on that port along with a description of the sentence and the last values that were sent with the 
sentence. Each sentence has a checkbox that can be used to filter it out; clearing a checkbox causes the 
sentence to be ignored and checking the box causes the sentence to be used.  

5. Use the Raw Data page to see the raw data stream as it arrives at the port. The bottom of this page 
contains a box where you can type an NMEA sentence to send to the device connected to the selected 
port. 

6. The Talker page is similar to the Sentences page, but shows the NMEA 0183 sentences that are being 
sent to the port.  

7. The GPS Status page shows information about any GPS signal that is being received on the selected port. 
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NMEA 0183 Data Logging Window 

Tools > Options > Instruments > Logging 

 

Coastal Explorer can save a log of all of the NMEA 0183 data it receives. This data can be useful when diagnosing 
problems with the interconnection of equipment on your boat, or possibly in legal cases after a boating 
accident. 

This window lets you enable or disable the logging feature, select the file to save the log to, and limit the size of 
that file. 

When the log file reaches the set size limit, the oldest data is removed from it to make room for the new data. 
For a very large file, this process can be somewhat time consuming so we recommend keeping the limit to 
around 10 MB or less. 
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Autopilot 

Tools > Options > Instruments > Autopilot 

The Autopilot window controls all of the options for the data that is sent to your autopilot as well as any other 
NMEA 0183 "Listener" devices that are connected to your PC. 

Unfortunately, the NMEA 0183 standard for communicating with an autopilot has been misinterpreted by some 
manufactures and has evolved over the years. This makes working with an autopilot less than automatic, and 
sometimes it can be downright difficult. Coastal Explorer tries to make it a little easier by having some built-in 
knowledge of how many autopilots work. 

The first step in getting your autopilot working is to try to select the manufacturer and model in the Model tab 
of the Autopilot window. If your autopilot's manufacturer is not in the list, then select Other and then review 
your autopilot's manual and check the settings in the Options and Sentences tabs. 

If you have other NMEA 0183 "Listener" devices connected to your PC, you might need to use the Sentences tab 
to add more sentences to the data that Coastal Explorer will send to those devices. Consult the documentation 
for your equipment to determine what sentences to send. Try not to select sentences that are not necessary as 
only a limited amount of data can be sent. If you attempt to send too much data, you will get "NMEA Port 
Clogged" messages from Coastal Explorer. When that happens, you can either turn off some sentences, or adjust 
the Time between updates value in the Options tab. 

Autopilot Model 
Tools > Options > Instruments > Autopilot > Model 

 

This window allows you to specify the manufacturer and model of your autopilot so that Coastal Explorer can be 
automatically configured to work with your system.  

To Set Up Your Autopilot 
1. Select the manufacturer of your autopilot from the list on the left. If you do not see your manufacturer 

listed, select Other, or to disable autopilot support, select None.  



 

50 

2. Select the model of your autopilot from the list on the right. If you do not see your model listed, select 
Other and the settings most appropriate for autopilots from the selected manufacturer will be selected. 
You may need to adjust these settings based on your autopilot's documentation.  

If you would like complete control over how information is sent from Coastal Explorer to your NMEA 0183 
system, use the Options and Sentences tabs to make your adjustments. 

Autopilot Options 
Tools > Options > Instruments > Autopilot > Options 

 

This window lets you control various aspects of how Coastal Explorer formats the information it sends to your 
autopilot and other NMEA 0183 devices. The default settings should work with most devices, but if something is 
not working quite right you might have to make some adjustments here. Please refer to the documentation for 
the devices you want Coastal Explorer to send data to in order to find the appropriate settings. 

Talker ID This is the type NMEA 0183 device that Coastal Explorer will claim to be when it transmits sentences. 
This should be set to II - Integrated Instruments unless you have equipment that requires something else (some 
Furuno autopilots are known to only listen to a GP - GPS Receiver, for example.) 

Time between updates Specifies the number of seconds to wait between each burst of NMEA 0183 sentence 
transmissions 

Always include checksum Checking this will cause Coastal Explorer to send a checksum value with every NMEA 
0182 sentence it transmits; when this is not checked, only those sentences specified as requiring checksums will 
have them. A checksum is a simple method of ensuring data transmission reliability. We recommend that this 
option be left on unless you experience problems with older NMEA 0183 equipment. 

Magnetic or True Bearings This specifies whether bearings should be sent as True or Magnetic (the default is 
True). Since the information about which option is selected is included with each bearing sent, most autopilots 
will work either way. However, some older autopilots ignore the true/magnetic settings and assume the bearing 
is one or the other. For these autopilots, you must select the appropriate option here. 

Send three-digit bearings (000-359) Some autopilots require bearings to be specified as three digits with leading 
zeros added to bearings less than 100 degrees. When this option is on, bearings are always sent with three digits 
before the decimal point. When this option is off, bearings are sent without leading zeros. 

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_Autopilot_Options.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_Autopilot_Sentences.htm
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Maximum waypoint name length Specifies the number of letters and/or digits that are allowed by your 
autopilot in a waypoint name. Names longer than this value will be truncated to fit (the default is 16). 

Use ALL CAPS Specifies that the autopilot does not accept lower-case letters so waypoints names should be 
converted to all capital letters before sending them. 

Numeric Precision - Bearing This specifies how many digits after the decimal point should be sent for bearings 
(the default is 2). 

Numeric Precision - Range This specifies how many digits after the decimal point should be sent for ranges (the 
default is 2). 

Numeric Precision - XTE This specifies how many digits after the decimal point should be sent for cross-track-
error distances (the default is 3). 

Numeric Precision - Fix This specifies how many digits after the decimal point should be sent for fixes (the 
default is 3). 

Numeric Precision - Speed This specifies how many digits after the decimal point should be sent for speeds (the 
default is 1). 

Select Default Options Press this button to restore all of the values on this page to their defaults. 

Autopilot Sentences 
Tools > Options > Instruments > Autopilot > Sentences 

 

This lists the various NMEA 0183 sentences that Coastal Explorer can transmit. You will need to refer to your 
equipment's documentation or experiment to find the right options. However, most autopilots will work with 
just the APA, APB, and BWC sentences selected.  

Try not to select sentences that are not necessary as only a limited amount of data can be sent. If you attempt to 
send too much data, you will get "NMEA Port Clogged" messages from Coastal Explorer. When that happens, 
you can either turn off some sentences, or adjust the Time between updates value in the Options tab. 
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Port Clogged 

Port Clogged is a warning condition unique to Coastal Explorer that is intended to help troubleshoot a common 
problem you might run into when combining the data from several NMEA 0183 instruments on a single NMEA 
0183 port.  

The problem stems from the fact that NMEA 0183 data is typically sent at a fairly slow speed and many devices 
send almost as much data as can be sent on a single NMEA 0183 port. When the data from more than one 
instrument is combined, there is sometimes more data to send than time will allow.  

While Coastal Explorer can't do anything about incoming data that is garbled due to a clogged port, it can 
prevent itself from creating the problem. The PORT CLOGGED warning specifically means that one of your Talker 
and/or Repeater ports currently has too much data being sent to it. While this warning is in effect, Coastal 
Explorer will stop sending lower priority sentences as often in order to prevent the data it is sending from 
getting corrupted.  

Several factors control the amount of data being sent to a port by Coastal Explorer. Probably the most important 
is the Repeat Rate which is found in the Tools > Options > Instruments > Autopilot > Options window. This 
controls how often Coastal Explorer will send updated data to the port. The number of seconds should be as 
small as possible to ensure that equipment that is using the data is always using relatively "fresh" data, but large 
enough that the port does not clog up. Two seconds is usually a good number.  

Another major factor is the set of sentences that Coastal Explorer sends. These are selected in the Tools > 
Options > Instruments > Autopilot > Sentences window. Only the sentences that need to be sent should be 
checked, but figuring this out can be very difficult. Unfortunately, most electronics manuals list all of the 
sentences that the device is capable of using but they don't list the minimum or even preferred sentences. Most 
modern autopilots really only need the APB and RMC sentences, but some other models may require other 
sentences instead. Check coastalexplorer.net for information about your specific model of autopilot.  

One other potential cause of port clogging is the Repeater option for NMEA 0183 ports. When this option is 
enabled, all of the NMEA 0183 data from all of the Listener ports and the data configured for Talkers is 
combined into a single stream and sent to the Repeater port. This option is almost never necessary, so think 
twice before turning it on.  

You can hook as many "talker" devices to your PC as you want without ever getting the PORT CLOGGED warning; 
the warning only has to do with the data that Coastal Explorer is sending to "listener" devices. We recommend 
using a separate port for each device, or using an NMEA Multiplexer only for devices that don't send a lot of 
data.  

It is important to realize that the Tools > Options > Instruments > Autopilot options really control all of your 
Talker ports. Typically this only ever means your autopilot, but sometimes you might have an NMEA 0183 data 
display or a radar that show navigation information, and the options set in this window will affect the data sent 
to all of these instruments.  
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Using AIS 

If you have an AIS receiver connected to your computer, Coastal Explorer will show you the locations and other 
information that it receives from other vessels in your area. 

To configure Coastal Explorer to use your AIS receiver, use the Tools > Options > Instruments window to setup 
the port the receiver is connected to. The automatic port detection should be able to find your AIS receiver. If 
you decide to manually configure the port, keep in mind that most AIS receivers use 38400 baud instead of the 
4800 baud used by most other NMEA 0183 devices. 

Once the port is configured, the AIS feature is mostly automatic; if Coastal Explorer receives AIS information, 
then the vessels will appear on the chart as small blue triangles pointing in the direction of the vessel's heading. 
If you zoom in on a vessel, and its size is being transmitted through the AIS, the symbol will scale with the chart 
(as long as the scaled symbol is longer than the normal triangle). 

A few options are available in the Tools > Options > AIS window. These options let you control how long a track 
to draw for each vessel and whether or not to draw predictor lines and names. 

To get detailed information about a particular AIS vessel, click on its symbol on the chart. Information about the 
vessel will appear in the Properties panel of the Task Pane. (If the Properties Task Pane has been hidden, right-
click on the vessel's symbol and select the Properties option.) 

You can also see a table listing various properties of all of the AIS vessels being tracked in the Navigation Object 
Browser. Use the Tools > Navigation Object Browser option and then select AIS Ships from the list of object 
types on the left side of the browser. 

When a Coastal Explorer has not received a signal from a vessel for 90 seconds, it considers that target to be 
"Lost" and will draw the vessel as a hollow triangle with a line through it. Lost targets will also flash until they are 
acknowledged by clicking on them unless the flashing option has been disabled in the Tools > Options > AIS 
window. Targets that are lost for a total of three minutes are removed from the chart. 

Coastal Explorer will calculate the "Closest Point of Approach" (CPA) for each AIS target and warn you if your 
course and the course of another vessel will come within 0.25 NM within the next five minutes. These targets 
are considered to be "Dangerous" and will flash red until they are acknowledged. The minimum allowed CPA 
and "Time to CPA" (TCPA) can be adjusted in the Tools > Options > AIS window. 

AIS Options 
Tools > Options > AIS 

Vessels 

Show Tracks causes a track to appear for each vessel picked up by the AIS receiver. The length of the track (in 
time) can be set with the Track Length option. 

Show Predictors causes each vessel to display a predictor line indicating approximately where the vessel will be 
if it maintains the same course and speed for a period of time. The predictor time used for AIS vessels is the 
same as the time set for your own boat in the Boat Properties. 

Show Vessel Names causes the names of vessels to appear near their symbol on the chart. (Coastal Explorer will 
attempt to prevent names from overlapping and causing too much clutter, so some vessel names may not 
appear even when this option is enabled.) When this option is disabled, you can selectively display the names of 
some vessels by right-clicking on a vessel and selecting the Show Name option. 
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Show Vessels with Class B Equipment can be used to show or hide vessels that are using Class B AIS 
Transponders. Normally this option should be enabled, but it can be used to help reduce chart clutter in areas 
with many smaller vessels. 

Show Dead Reckoned Position causes the locations of vessels to be predicted and displayed every second rather 
than only when a position report is received. The predicted location of a vessel appears as a semi-transparent 
version of the vessel's symbol. 

Other Targets 

Show Base Stations causes the locations of AIS Base Stations to be shown on the chart. 

Show Aids to Navigation causes the locations of AIS Aids to Navigation (AtoNs) on the charts. 

Show Search and Rescue Planes causes the locations of search and rescue planes (that are transmitting an AIS 
signal) to appear on the chart. 

Safety 

Flash Lost and Dangerous Targets causes targets that have been lost or are considered dangerous to flash on 
the chart. (Targets are considered to be lost when a position report has not been received from them in the past 
90 seconds.) 

The Hide Lost Targets After option specifies how long a target should be displayed after having been lost. 

The Closest Point of Approach (CPA) and Time to CPA (TCPA) for each vessel is calculated each time a vessel or 
your boat moves. These values indicate how close you will approach the other vessels provided no one changes 
course or speed. Vessels are considered dangerous when they will be closer than the Danger CPA distance 
option within the Danger TCPA time option. Dangerous vessels appear in red and may flash (based on the option 
mentioned above). 

Assume Stationary Targets are Safe prevents a target that is not moving from being considered dangerous. This 
option is very handy when you are in areas with a lot of moored vessels that you will be passing close to, but are 
not likely to collide with. 
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Guide Books 
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Guide Books 

The Browser can display Guide Book information for areas that you select on the chart. This information comes 
from the Coastal Explorer Network, NOAA US Coast Pilot, NGA Sailing Directions, or other optional guide books 
you may have installed. 

To access the Guide Books 
 use View > Browser Panel > Guide Book menu command, or  

 use the Browser Panel > Guide Book command on the main toolbar, or  

 use the Guide Book command on the Browser title menu,  

 use the Guide Book command on the right-click menu for the chart.  

While the Browser is open, clicking anywhere on the chart will show nearby information from the installed guide 
books. The title of the Guide Book Browser has a Nearby Places button that can be used to display the Nearby 
Places Task Pane which contains a list of nearby places that are covered by the Guide Books. 

The US Coast Pilot books are an optional component and are not included if you selected the Minimum Install 
option when you set up Coastal Explorer. If you need to install the US Coast Pilot books, you may insert the 
original Coastal Explorer CD-ROM, run Setup again, choose the Custom Install option, and select the books you 
would like. 

Additional Guide Books may be downloaded from coastalexplorer.net. 

  

http://coastalexplorer.net/


 

Coastal Explorer Reference  57 

Community Guide Book 

Coastal Explorer and the Coastal Explorer Network offer a community driven cruising information system known 
simply as the "Guide Book." The Guide Book can be accessed from within Coastal Explorer as well as on the 
CoastalExplorer.net website. 

To enable the Guide Book within Coastal Explorer, select Tools > Options > Coastal Explorer Network and enter 
your Coastal Explorer Network username and password. 

Once your account information has been entered Coastal Explorer will automatically download updates to the 
Guide Book whenever you start the program or use the Sync command in the Guide Book Browser. 

Guide Book Places will appear on your chart as small Coastal Explorer icons. Clicking on one of these icons will 
display a popup tip about the place. Double-clicking on one will display the Guide Book Browser Panel and show 
all of the information about the place. 

Contributing to the Guide Book 
Coastal Explorer has a command called Insert Guide Book Place which can be found on the context menu for 
charts (the menu you get when you click the right-mouse button). This command lets you add information to the 
Guide Book. 

Selecting Insert Guide Book Place will open the Guide Book Place Entry Editing Browser Panel. Enter a title for 
your Guide Book Entry and the Content of your article in the appropriate boxes. You can also attach photos or 
other files by clicking the Attach or Paste buttons. 

The Attach button will display a file selection window to let you select the file you want to attach to your entry. 

The Paste button will attach something that you have previously copied to the clipboard. It is possible to copy 
images from web pages and paste them into your entry. In this case, Coastal Explorer may make a thumbnail of 
the image and also attach a link to the original page in order to avoid copyright infringement. 

The Link button displays a window where you can add a hyper-link to your entry. Enter a title for the link (what 
people will see) and a Link address (such as "http://rosepointnav.com/") before pressing OK. 

When you have finished your Guide Book Entry, press the Done button on the toolbar. You will then return to 
the Guide Book Browser where you should see your new entry. Pressing the Sync button will synchronize 
Coastal Explorer with the Coastal Explorer Network which will send your new entry to the Internet and retrieve 
any entries that others have added since the last time you synchronized. 

 





 

Coastal Explorer Reference  59 

Tides 
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Tide and Tidal Current Predictions 

Coastal Explorer can predict the tide level and current set and drift for thousands of tide and current stations in 
the US and some other parts of the world. These predictions can be displayed as graphs over time in the 
Browser or for a particular instant directly on the chart. 

 

WARNING: Tidal current predictions are based on observational data taken at the specific 
location. Since extremes of meteorological conditions have been excluded from the analyses and 
predictions, the predicted values should be considered as those expected under average weather 
conditions. During times when weather differs from what is considered average for the area, the 
user must be aware that actual water levels and currents may vary from those predicted. 
Generally, prolonged onshore winds or a low atmospheric pressure can produce higher levels than 
predicted, while the opposite can result in lower levels than those predicted. 

All tide prediction times are adjusted for the local time currently selected for your computer. To change your 
computer's time zone or daylight saving option, use the "Date and Time" option in the Windows Control Panel.  

Tide and current station symbols appear on the chart at the location provided by NOAA. In some cases the 
position is provided only to the closest degree and minute which means the symbol can only appear in the 
general vicinity of the station. Sometimes the symbols may even appear on land. The symbol's location should 
only be used as an indication of the general location of a station. 

To prevent crowding the chart, reference stations are not shown at scales smaller than 1:10,000,000 and 
subordinate stations are not shown at scales smaller than 1:500,000. 

TIP: Use the Highlight Objects button on the toolbar to make the tide and current stations stand out 
against the chart. 

Tide Level Prediction Procedures 

To see tide level predictions on the chart: 
 Use the Format > Tide Levels command to show and hide the tide station symbols.  

 Open the Tide Browser; the tide station symbols will appear whenever this browser is open.  

To see details about a tide station: 
 Click on a tide station symbol to see its name, location, a prediction for the current time, and the trend 

(rising or falling).  
 Right-click on a tide station symbol and select the Properties command to see more information about 

the station in the Properties Panel.  

To see a tide level prediction graph: 
 Right-click on the chart where you want to see a prediction and select Tide Level Prediction from the 

menu. This will open the Browser on the nearest tide station.  

 Double-click on a tide station symbol to show a tide level graph in the Browser. See Using the Tide Level 
and Tidal Current Prediction Browser for more information.  

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/TideGraph.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/TideGraph.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/TideGraph.htm
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Tidal Current Prediction Procedures 

To see tidal current predictions on the chart: 
 Use the Format > Tidal Currents command to show and hide the tidal current station symbols.  

 Open the Tidal Current Browser; the current station symbols will appear whenever this browser is open.  

To see details about a current station: 
 Click on a current station symbol to see its name, location, a prediction for the current time, and the 

time of the next slack.  
 Right-click on a current station symbol and select the Properties command to see more information 

about the station in the Properties Panel.  

To see a tidal current prediction graph: 
 Right-click on the chart where you want to see a prediction and select Tidal Current Prediction from the 

menu. This will open the Browser on the nearest current station.  
 Double-click on a current station symbol to show a tidal current graph in the Browser. See Using the 

Tide Level and Tidal Current Prediction Browser for more information.  

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/TideGraph.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/TideGraph.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/TideGraph.htm
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Using the Tide Level and Tidal Current 
Prediction Browser 

Scrolling the graph: 
 Drag the graph left or right with the mouse by pressing and holding the left mouse button.  

 Move the mouse near the left or right sides of the graph until the cursor turns into an arrow and then 
press the left mouse button to scroll in that direction.  

 Click the Select Date button on the Browser's toolbar and select a date from the popup calendar.  

 Use the Left or Right Arrow Keys (you may need to click on the Browser first). Hold down the Shift key 
when using an Arrow Key to scroll faster.  

Zooming in and out on the graph: 
 Use the + and - buttons on the Browser's toolbar to zoom in and out on the graph.  

 Use the + and - keys (you may need to click on the Browser first).  

Adjusting the virtual time: 
 Click anywhere on the graph to set the virtual time.  

 Drag the Real or Virtual Time mark to a different time on the graph.  

 Use the time changing buttons on the Browser's toolbar.  

Resuming Real Time: 
 Double-click on the Virtual Time mark.  

 Click the "Go To Now" button on the Browser toolbar.  

 Click the Virtual Time panel in the lower-right corner of the chart panel.  

 Press the Home key (you may need to click on the Browser first).  
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Weather 
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Weather 

Coastal Explorer can be used to download and view text weather forecasts and graphical forecasts, or "weather 
maps", which are overlaid on your chart. Both of these features require some sort of Internet access in order to 
retrieve the forecasts. 

 

 

IMPORTANT DISCLAIMERS 
The coastalexplorer.net weather servers normally operate 24 hours a day, seven days a week, but 
we cannot guarantee they will always be available. Therefore, the weather forecast features in 
Coastal Explorer must not be relied upon as your sole source of weather forecast information. 
 
Weather forecasts are provided "as is" and the user assumes the entire risk related to their use. 
Rose Point Navigation Systems, its licensors, and the National Weather Service disclaim any and 
all warranties, whether express or implied, including (without limitation) any implied warranties 
of merchantability or fitness for a particular purpose. In no event will Rose Point Navigation 
Systems, its licensors, or the National Weather Service be liable to you or to any third party for 
any direct, indirect, incidental, consequential, special or exemplary damages or lost profit 
resulting from any use or misuse of these forecasts. 
 
The computer models used to generate the graphical weather forecasts predict "typical" weather 
conditions and will not produce accurate forecasts for severe storms, hurricanes, etc. These 
predictions have not been validated by a marine weather forecaster and may be misleading. 
Mariners are urged to use these forecasts in conjunction with forecaster generated forecasts. 
 

Text Weather Forecasts 
Text weather forecasts are prepared by skilled meteorologists at the National Weather Service based on many 
different data sources. These forecasts are similar to the reports you hear on the NOAA Weather Radio service. 

To access a text weather forecast, click the right mouse button on the chart near the area you want the forecast 
for and select the Weather option from the menu. Alternatively, use the Tools > Weather option in Planning 
Mode or click on the Coastal Explorer logo in Cruise Mode and select the Weather option from that menu. The 
text weather forecasts appear in the Browser below the chart. 

An Internet connection is required for downloading the text weather forecasts, but once a forecast has been 
downloaded you will be able to read it up until its expiration time even when you are not connected to the 
Internet. 

Graphical Weather Forecasts 
Graphical Weather Forecasts are produced by computers from mathematical formulas based on known weather 
patterns. The graphical weather forecasts contain a geographical grid of predicted values for weather attributes 
such as temperature, air pressure, wind, etc. Coastal Explorer can superimpose these values on your chart and 
even animate them over time so you can see how the weather might affect your plans. 

The general nature of the graphical weather forecasts makes them more suitable for long-range voyages rather 
than short trips (where the text weather forecasts are usually more appropriate). 
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To access a graphical weather forecast, open the Weather Browser using the Tools > Weather option or by right-
clicking on the chart and selecting the Weather option from the menu. Then click on the Graphical tab at the 
top of the Weather Browser. 
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Using the Graphical Weather Forecast 
Browser 

Tools > Weather > Graphical 

The Graphical page of the Weather Browser lets you select from several built-in weather maps, or create a 
custom map that better suites your needs. These weather maps are overlaid on your chart and may be animated 
through time to let you see how the weather might affect your journey. 

The first thing you will need to do is get a weather forecast to your computer and Coastal Explorer provides two 
ways to do this. If you have Internet access on your computer, the easiest way to get weather is by pressing the 
Download button on the toolbar for the Graphical Weather Forecast Browser. This option leads to a window 
that lets you select the type of information you want and the area you want it for. After you've made your 
selections, the weather forecast data is downloaded from the coastalexplorer.net servers and will be displayed 
on your chart. 

Coastal Explorer can use the weather data from coastalexplorer.net or from files known as "GRIB Files" which 
are an International standard for gridded weather forecast data. These files are available from NOAA and other 
locations on the Internet. To open a GRIB File, use the File > Open command or the Open button on the 
Graphical Weather Forecast Browser toolbar. 

Controlling What You See 
The left side of the Graphical page of the Weather Browser provides you with a list of Weather Map options to 
choose from. Select one of these weather maps or choose Custom to make your own. To the right of the 
weather map options is a list of the layers (weather elements) used in the selected weather map. A legend is 
shown for each layer as well as the range of dates the loaded forecast data is valid for. As you move the mouse 
cursor over the chart, values for each layer at the mouse cursor will appear to the right of the legends. 
Underneath each value is a time offset which indicates how far into the forecast that value is for. Obviously, 
values further into a forecast should be trusted less than values closer to the beginning. 

When you make a custom weather map, you can select the layers that appear in your map and how each layer is 
presented. Use the check boxes to turn individual layers on and off. To change the way a layer is presented on 
the screen, double-click on the legend and use the window that appears to select the style and colors for that 
layer. 

The built-in weather maps are always presented the same way and are not affected by the options you select for 
your custom weather map. 

The Transparency button on the toolbar lets you control how much of your chart shows through the filled-in 
parts of the weather forecast overlay. When you press this button, a slider will appear. Moving the slider all the 
way up will make the layers with the "gradient" style completely transparent, and moving the slider all the way 
down will make them completely opaque. 

Changing the Forecast Time 
Five buttons on the toolbar let you control the Virtual Time which is used to determine the time of the forecast 
data you see. These buttons let you go back and forward one day or one hour at a time, or to reset the Virtual 
Time to the current (real) time. You can move time back or forward by more than one day or hour by holding 
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down the appropriate button. The weather forecast displayed on the chart will change to show the predicted 
values for the Virtual Time you select. 

The Downloading Weather Forecast Window 
Tools > Weather > Graphical > Download 

 

The Download Weather Forecast window let you download weather forecasts from CoastalExplorer.net. You will 
need an Internet connection for this. If you do not have Internet access on your boat's computer, but can visit a 
library or Internet Cafe, visit coastalexplorer.net to download weather forecasts to a floppy disk or USB Flash 
Drive. 

To access the Download Weather Forecast window, click the Download button on the Graphical Weather 
Forecast Browser's toolbar. 

To Download a Weather Forecast 
 Select the region you want a forecast for. You can select one of the pre-set regions from the list, or draw 

a rectangle around an area on the map.  
 Select the types of information you want to download. Each type, or layer, has a check box next to it and 

each layer that is checked will be included in your download.  
 Select the number of days you would like to include in your forecast. You can select up to 15 days, but 

that much information might not be available. In this case, your forecast will include as many days as are 
available.  

 Press OK  

Your download will start and a progress indicator will let you know how much data still needs to be downloaded. 
You can continue to use Coastal Explorer as the download progresses. 

The Format Weather Layer Window 
You can get to this window by selecting the Custom weather map option and then double-clicking on a weather 
data item in the Browser. 

http://coastalexplorer.net/
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This window lets you control the way a weather layer appears on your custom weather map. The options 
selected here do not affect the built-in weather maps, just your custom weather map. 

The Style of the weather layer can be: 

Contour This shows contour lines indicating different values for the data. This style is commonly used for 
pressure. 

Contour and Gradient This shows contour lines indicating major value changes as well as a color gradient so 
show more subtle changes. 

Gradient This shows only the color gradient and is commonly used for temperature. 

Wind Barb This shows wind as a standard meteorologist's "wind barb". 

Arrows This shows wind as an arrow pointing in the direction the wind is blowing. The arrows get larger with 
stronger winds. 

Show Text Label This option causes contours to be labeled with their value. 

The Color of the weather layer can be: 

Gradient Select from several sets of color ranges that are used to indicate values. 

Single Color Select a single color to show all values, but use the value to control how transparent the color 
appears to be. This option is typically used for Rain. 
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Virtual 
Instrument 

Panels 
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Virtual Instrument Panels 

One of the Task Pane options is called Instruments and it displays information received by the instruments 
connected to your computer as well as some things calculated by Coastal Explorer. Many different Instrument 
Panels are available and you can decide which of them to display.  

Each Instrument Panel has a menu that may be accessed by clicking the right mouse button while pointing at the 
instrument panel. The menu allows you to change what is displayed in the panel as well as close the panel or 
add another one. Some panels also add commands to the menu that are specific to that type of panel. 

Showing the Instruments 
 To show the Instruments, click on the Instruments Task Bar tab on the far right side of the screen. 

Adding another Instrument Panel 
 To add another Instrument Panel, right click anywhere in the Instruments Task Pane and select the Add 

another panel... option. This will open the Add Instrument Panel window where you can select the data 
you want to display and how you want it displayed. 

Removing an Instrument Panel 
 To remove an Instrument Panel, right click on that panel and select the Close this panel option. 

Changing an Instrument Panel 
 To change the type or format of an Instrument Panel, right click on that panel and select the Change 

panel type option. 

Scrolling the Instruments 
 If you need to scroll your Instrument Panels because you have configured more than will fit in the 

Coastal Explorer window, you can do so by dragging from anywhere that is not a button or other control 
with the left mouse button. Some Instrument Panels use the mouse for other things, so if dragging 
doesn’t scroll the window, try pointing at a different panel before dragging. 

 If you have a scroll-wheel on your mouse, you can point to the Instruments and use the wheel to scroll. 
(However, using the mouse wheel over the Chart Overview will cause it to zoom in and out.) 

Rearranging Instrument Panels 
You can change the order of the Instrument Panels a few different ways: 

 Hold down the Alt key and drag a panel up or down with the mouse.  

 Enter Customize Mode and drag a panel up or down with the mouse. (The Alt key is not necessary while 
in Customize Mode.)  

 Select the Instruments page of the Customize window, select an Instrument Page and Instrument Panel, 
and use the Move Up or Move Down buttons.  
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Using the Instrument Panel Window 
The Instrument Panel Window is used to add an Instrument Panel to the Instruments Task Pane or to change 
one that is already there. 

 

The left side of the window has a list of data items that can be displayed. Since this list can be fairly long, a drop-
down list of categories is provided that lets you first select the category of data items to see in the list. When the 
window first appears, All Categories are shown. 

REVIEW: The Source and Instance options have not been implemented yet so are currently disabled. 

The right side of the window has a preview of the Instrument Panel. Above the preview is a list of different 
display types that can be used for the selected data item. Below the preview is a Display Options button that 
will open another window to give you fine control over how the Instrument Panel appears. The display options 
are based on the data item and display type that you've selected, and not all combinations have options that can 
be changed, so the button will not always be enabled. 

To use this window, first select the data you want to display, using the category option to help find the data if 
necessary, then select the display type you want, finally change any display options and press OK. 
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Data Items 

Coastal Explorer can use and display many different “data items” that are either received from an instrument 
connected to your PC or are calculated by Coastal Explorer. These data items include: 

Active Route Name 
Active Waypoint Name 
Absolute Humidity 
Activate Route 
Air Temperature 

AIS Plotter 
AIS Targets 
Alarm Status 
Apparent Wind Angle (AWA) 
Apparent Wind Speed (AWS) 
Barometric Pressure 
Battery Voltage 
Battery Current 

Battery Temperature 
Bearing to Waypoint (BRG) 
Bottom Look Ahead 
Chart Overview 
Course Over Ground (COG) 
Cross Track Error (XTE) 
Date and Time 
Daylight Mode 

Deactivate Route 
Depth 
Dew Point 
Engine RPM 
Engine Alternator Voltage 
Engine Boost Pressure 
Engine Coolant Pressure 
Engine Fuel Flow Rate 

Engine Fuel Pressure 
Engine Hours 
Engine Load 
Engine Oil Pressure 
Engine Oil Temperature 
Engine Temperature 
Engine Tilt/Trim 
Engine Torque 

Engine Warning 
Engine Check 
Engine Over Temperature 
Engine Low Oil Pressure 
Engine Low Oil Level 
Engine Low Fuel Pressure 
Engine Low System Voltage 

Engine Low Coolant Level 
Engine Water Flow 
Engine Water in Fuel 
Engine Charge 
Engine Preheat 

Engine High Boost Pressure 
Engine Rev Limit Exceeded 
Engine EGR System 
Engine Throttle Position Sensor 
Engine Emergency Stop Mode 
Engine Warning Level 1 
Engine Warning Level 2 
Engine Power Reduction 

Engine Maintenance Needed 
Engine Comm Error 
Engine Sub or Secondary Throttle 
Engine Neutral Start Protect 
Engine Shutting Down 
Estimated Time of Arrival (ETA) 
GPS Status 
Ground Wind 

Ground Wind Direction (GWD) 
Ground Wind Speed (GWS) 
Heading (HDG) 
Event 
Instant Route 
RBL From Boat 
Lateral Slide 
MOB 

Radar 
Nearby Places 
Next WP 
Previous WP 
Obstacles 
Operating Mode 
Pitch 
Radar Cursor (lat/lon) 

Radar Cursor (rng/brg) 
Variable Range Marker 1 (VRM) 
Variable Range Marker 2 (VRM) 
Electronic Bearing Line 1 (EBL) 
Electronic Bearing Line 2 (EBL) 
Range to Waypoint (RNG) 
Rate of Turn (ROT) 

Relative Humidity 
Reset Display 
Reset XTE 
Roll 
Route Overview 

Rudder Angle 
Search Results 
Speed Over Ground (SOG) 
Start New Track 
Tank Level 
Tank Capacity 
Time To Go (TTG) 
Tracking 

NMEA 0183 Transducer (XDR) 
Transmission Gear 
Transmission Oil Pressure 
Transmission Oil Temperature 
Transmission Warning 
Transmission Check 
Transmission Over Temperature 
Transmission Low Oil Pressure 

Transmission Low Oil Level 
Transmission Sail Drive 
Trip Log 
True Wind Angle (TWA) 
True Wind Direction (TWD) 
True Wind Speed (TWS) 
Vessel Position 
Velocity Made Good (VMG) 

Video 
NoLand VS52 A1 Input 
NoLand VS52 A2 Input 
NoLand VS52 A3 Input 
NoLand VS52 A4 Input 
NoLand VS52 A5 Input 
NoLand VS52 Flo Input 
NoLand VS52 Fhi Input 

NoLand VS52 1/P1 Input 
NoLand VS52 1/P2 Input 
NoLand VS52 1/P1 - 1/P2 Input 
NoLand VS52 D1 Input 
NoLand VS52 D2 Input 
Water Speed (STW) 
Water Temperature 

 

NOTE: Some data items are only supported via add-ons or interfaces other than NMEA 0183 (such as NMEA 2000). 
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Heading Displays 

Navigation Compass 
The Navigation Compass shows your vessel's heading (or course when the heading is unknown). Both the true 
and magnetic headings are shown numerically and an analog compass display shows either the true or magnetic 
heading depending on the bearing setting in the Units of Measurement page of the Options Window. The 
analog compass display shows the current heading at the top of the dial.  

When a waypoint is active, the Navigation Compass also shows the range and bearing to that waypoint and the 
Time To Go to that waypoint. The bearing to the waypoint is shown as an arrow in the analog compass display. 
When the arrow is pointing straight up, aligning with the red lubber's line, the vessel is heading straight for the 
active waypoint. When the arrow is pointing to the right of the lubber's line, the vessel needs to be steered to 
starboard, and when it points to the left, the vessel should be steered to port.  

 

Mini-Compass 
The mini compass uses a lot less space than the Navigation Compass, but also shows your heading and the 
direction to the active waypoint graphically. 

 

 

 

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Opt_Measurements.htm
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Route Overview 

The Route Overview displays the active route at a constant scale and relation to your vessel. It is similar in 
concept to the "Highway" displays common in some navigation equipment. Your vessel is shown in the center of 
a scale near the bottom of the console. Each tick mark on the scale represents 0.25 nm.  

The active route will appear in the console to show your relation to nearby waypoints. Leg lines are drawn as 
thick lines of three colors; the thin center line of a leg line represents the leg line as it was plotted, the green 
represents the area 0.25nm on each side of the plotted line and the yellow outside of it indicates the next 0.25 
nm, outside of which the cross-track-error alarm will start to go off. A thin line is always drawn between the 
boat and the active waypoint to show its relative bearing.  

To use the Route Overview, simply activate a route and then keep steering in such a way that the green part of 
the route is under the boat which means you are within an acceptable distance from the centerline of the route.  
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Wind Displays 

All of the wind panels require an NMEA 0183 or NMEA 2000 compatible wind vane and anemometer to be 
connected to the PC and some require your speed over ground, course over ground, and heading information as 
well. 

Digital displays are available for Apparent Wind Angle, Apparent Wind Speed, Ground Wind Direction, Ground 
Wind Speed, True Wind Angle, True Wind Direction, and True Wind Speed. 

Four different large “analog” wind panels are also available: 

Apparent Wind Angle This panel shows the apparent wind as it is measured from from your wind vane and 
anemometer. 

True Wind Angle This panel shows the true wind calculated from the apparent wind and your speed over 
ground. 

True Wind Direction This panel is similar to True Wind Angle, but the angle is converted to a compass direction 
by adding you heading. If your heading is not available from your instruments, your course over ground will be 
used, but the calculated direction will not be as accurate. 

Ground Wind This panel shows the wind speed and direction over ground using a compass display. The 
calculations for Ground Wind depend on having an accurate course and speed over ground, heading, and 
apparent wind. If any of these values is not available from your instruments, the Ground Wind will not display. 
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Depth and Water Temperature 

These displays require an NMEA 0183 or NMEA 2000 depth sounder and the Water Temperature Console 
requires that it have a temperature sensor. 

Graphs 
The depth and water temperature graphs panels display the current depth and water temperature along with an 
auto-scaling graph of the past two minutes. Both panels actually show the current values of both depth and 
water temperature, but only graph their own value. 

 

Mini-Graph 
The mini-graph options are a more compact form and only show a single value (depth or water temperature): 
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Obstacles 

The Obstacles Panel searches the chart database for obstacles and warnings in the area between the boat and 
the location along the current course that the boat will be in a few minutes at the current speed. A list of 
warnings is displayed in the panel. 

This feature requires vector charts covering the area in question as there is no way to perform this kind of 
search on raster or photo charts. It also requires that you are moving and that the PC is receiving a valid GPS 
signal indicating where you are, what direction you are moving, and how fast you are moving. 

Please keep in mind that Coastal Explorer cannot predict all obstacles (things like logs and other boats usually 
aren't listed in the chart database) and that the charts you have don't necessarily contain all the known 
obstacles.  

Although you will still need to keep a vigilant watch off your bow, the Obstacles Panel can alert you to many 
things you might not see out there such as warnings, covered rocks, regulated traffic zones, and military test 
areas. 
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AIS Displays 

AIS Plotter 
The AIS Plotter is a North Up display centered on your vessel that shows AIS vessels within ½ NM. Your vessel 
appears as a green triangle in the center of the display and is oriented based on your heading (or course over 
ground if heading is not available). AIS targets normally appear as blue triangles, but “dangerous” targets are 
displayed in red. Use Tools > Options > AIS to adjust what AIS targets are considered to be dangerous. 

 

Nearby AIS Targets 
The Nearby AIS Targets display shows the nearest 100 AIS targets in a list sorted by their distance to your vessel. 
Clicking on a target in the list will expand the information displayed for that target. 
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GPS Status Display 

Mini GPS Status 
The mini GPS Status display shows only the type of fix being received and can be any of these values: 

D.R. Dead reckoning mode is active 
NO GPS No GPS fix has been received 
LOST GPS A GPS fix was received in the past, but not for some time 
INVALID GPS FIX The GPS is reporting that its fix is not valid 
GPS FIX The GPS is reporting a standard fix 
DGPS FIX The GPS is reporting a differential fix 
ESTIMATED The GPS is reporting that its fix was estimated 
MANUAL The GPS is reporting that its fix was manually entered 
SIMULATED The GPS is reporting that its fix is simulated 

 

Full GPS Status 
The GPS Status Console shows which satellites are being used to determine your position as well as their 
locations in the sky, their signal strengths, and several other bits of information. 

 

The top-left of the console shows a graphical view if where the satellites are in the sky. The dot in the sky graph 
indicates the position and the number identifies the satellite. The same numbers appear below the bars in the 
Signal Strength graph at the bottom of the console. The number inside or above each bar as well as the height of 
the bar indicates the strength of each signal. 

The values in the top-right part of the console include: 

FIX What kind of fix is being reported by the GPS. This may be INVALID if a fix is not being 
received, GPS for a normal GPS fix, DGPS for a Differential GPS fix, ESTIMATED if the GPS 
unit is making a guess, or SIMULATED if the GPS unit is in demo mode. While you are 
cruising, the fix should always be GPS or DGPS depending on the type of GPS you have and 
where you are. 
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UTC This is the Universal Time Coordinated received from the satellites. It is the current 
standard time in Greenwich, England which is the center of time on Earth. 

ALT This is the altitude of the GPS antenna above mean sea level according to the GPS receiver. 
Please be aware that the vertical accuracy (altitude) of a GPS is very different from the 
horizontal accuracy (latitude/longitude). 

G-SEP This is the geoidal separation (the difference between the geoid - mean sea level - and the 
WGS-84 ellipsoid) at your location according to the GPS receiver. 

HDOP The current Horizontal Dilution Of Precision. This is a value that indicates the level of 
uncertainty in the horizontal position (latitude and longitude) that is being supplied by the 
GPS receiver. Lower values indicate better accuracy. 

STATION This is the differential station identifier being used by the GPS receiver if it has a DGPS fix. 

DGPS AGE This is the age, in seconds, of the last differential update. 
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Miscellaneous Displays 

Digital Display 
Most data items can be displayed in a simple digital form like this: 

 

Chart Overview 
REVIEW: Add this! 

Trip Log 
REVIEW: Add this! 

Search Results 
REVIEW: Add this! 

Nearby Places 
REVIEW: Add this! 

Vessel Position 

 

Rudder Angle 

 

Cross Track Error 
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Command Buttons 

It is possible to add command buttons to the Instrument Task Pane for some commands that you want instant 
access to but are not part of the other toolbars. The commands that are available include: 

Activate Route Displays the Activate Route window so you can select a route to activate. 

Daylight Mode Cycles between the daylight, dusk, and night color sets. 

Deactivate Route Deactivates the currently active route. 

Event Inserts an event at the current vessel location. 

Instant Route Starts Insert Instant Route mode; click on a chart where you want to navigate to 
in order to create the instant route. 

MOB Starts Man Overboard mode. 

Next WP Activates the next waypoint in the active route. 

Operating Mode Cycles between plan and cruise modes. 

Previous WP Activates the previous waypoint in the active route. 

RBL From Boat Inserts a range/bearing line from your vessel location; click on a chart where 
you want the other end of the line. 

Reset Display Resets the screen to the default configuration: one chart view, centered on 
boat, north up. 

Reset XTE Resets the cross track error. 

Start New Track Start recording a new track. 

Tracking Turn tracking on or off. 
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The Chart 
Viewer 
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Using the Chart Viewer 

In both Planning and Cruising mode, most of the Coastal Explorer Window is used to show the chart and the way 
you use the chart is exactly the same in each mode. 

The chart may be scrolled around and zoomed in and out to show to show different areas. These are very 
common operations, so Coastal Explorer provides a few ways to perform them. 

 

WARNING: Zooming in on a chart past its scale is like using a magnifying glass on a paper chart; it 
might seem “bigger,” but you aren’t seeing any more detail. With raster charts, the problem is 
fairly obvious as lines start to get thick and symbols get large, but vector charts don’t scale the 
same way and can cause a false sense of detail which can be dangerous. When the overscale 
indicator appears, make sure you are not relying on detail that is not really there! 
 

This is what the overscale indicator looks like:  
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Selecting Chart Types 

Coastal Explorer can display vector charts, raster charts, photo charts, topographic maps or a combination of 
chart and map types. 

The Custom... option on the Chart Type control on the main toolbar provides you with complete control over 
type types of charts displayed. 

To select chart types for display using the toolbar: 
 Use the Chart Type control to select All Charts, Vector+Raster (both vector and raster charts), Vector 

Charts, Raster Charts, Photo Charts, Topographic Maps, or select Custom... to see a window with more 
options.  

To select chart types for display using the menus: 
 Use the Vector Charts, Raster Charts, or Photo Charts options on the Chart Types sub-menu of the 

Format menu.  

To select chart types for display using the keyboard: 
 Press the V key to show vector charts 

 Press the R key for raster charts 

 Press the P key for photo charts.  

Hold down the Shift key when using V, R, or P to turn just that type of chart on or off. In other words, if you are 
viewing vector charts and you want to view both vector and raster, you can press Shift+R to turn raster charts 
on without turning vector charts off. 
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Quilting 

Exploring an area or planning a trip usually requires multiple charts. "Quilting" is the technique of digitally 
"stitching" together multiple charts so that everything lines up correctly. 

When quilting is on, Coastal Explorer will search your chart portfolio for the "best" charts to display given the 
area you are looking at, the viewing scale your are zoomed in to, and the type of chart you have selected, and 
then fill as much of the screen as possible with those charts. 

When Coastal Explorer is picking the charts to include in the quilt, it will only select charts that have scales that 
are reasonably close to the viewing scale, so if you are not seeing the chart you think you should, you may need 
to zoom in or out for it to appear. 

When the View > Chart Outlines option is enabled, an outline of each chart is displayed even when the chart will 
not be included in the quilt because of the difference in scale. When you use the Zoom Control on the main 
toolbar, the outlines of charts that are within range of the viewing scale are shown thicker than the other chart 
outlines. 

Sometimes you may want the quilting feature to be on, but have a particular chart that you do not want 
included. You can hide or show a particular chart by clicking the right mouse button on that chart, selecting the 
Charts Here option from the menu, and then selecting the chart from the menu of charts. 

When quilting is off, Coastal Explorer will search for the best chart that covers the center of the screen and 
display only that chart. You can override Coastal Explorer’s decision and select your own chart to display by 
clicking the right mouse button on the chart and selecting a chart from the Show Chart list. Selecting the 
Automatically Select Best Chart option will let Coastal Explorer decide which chart to display again. 

Whether quilting is on or off, the parts of the screen that are not covered by a real chart are filled with a base-
map. While it may seem like a pretty detailed map of the world's coastlines, the base map must not be used for 
navigation as it lacks the detail that is necessary. Nonetheless, the base map may be used to locate features with 
the gazetteer and guide books, or get an overview of your Navigation Objects over a large area. 

To turn the quilting feature on or off: 
 Use the Quilting option on the View menu.  
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Scrolling and Zooming 

Scrolling and zooming are fundamental operations that you will do a lot in Coastal Explorer. With the quilting 
feature turned on, Coastal Explorer will automatically select the best charts to show from your portfolio as you 
scroll around and zoom in and out. Because scrolling and zooming are so important, Coastal Explorer provides 
you with several ways of doing them both using the mouse or keyboard. 

When the chart window is split, all of the keyboard, menu, toolbar, and chart overview methods of scrolling and 
zooming will only affect the chart panel on the right. The mouse methods will affect whatever chart panel the 
mouse is pointing at. 

To scroll with the keyboard: 
 The Arrow Keys will move the displayed chart area in the direction of the arrow.  

 Holding down the Shift key while pressing an Arrow key will double the scrolling speed.  

 Using the Page Up key will move the chart display in the direction of your boat's heading, or in the 
direction of the next waypoint when in Course Up mode. The Page Down key will move the chart display 
in the opposite direction.  

 The Home key will move the chart display to where your boat is and resume the last used Auto Scrolling 
mode (Follow Boat, Look Ahead, etc.). Subsequent presses will cycle through the various Auto Scrolling 
modes.  

To scroll with the mouse: 
 Click the mouse near the edge of the chart where the cursor changes to a big arrow. Once you've started 

to scroll this way, you can move the mouse around to change the direction and speed of scrolling.  

 Select the Scrolling Mouse Tool with the button on the main toolbar. When this mouse tool is active, 
you can click anywhere on the chart to drag it around.  

 When the Select Mouse Tool is active, hold down the Alt key when you click the left mouse button to 
temporarily activate the Scrolling Mouse Tool as you drag the mouse around.  

 If your mouse has a middle (or wheel) button, press and hold that button while you drag the view 
around when the Select Mouse Tool is active.  

Overscale Warning 
Because Coastal Explorer will let you adjust the viewing scale of the charts to anything between 1:1,000 and 
1:100,000,000, there will be times that the chart image you see has been magnified to the point of implying 
more detail than is really there. This is pretty obvious with raster charts as they start to look blocky, but vector 
charts tend to stay nice looking at extreme magnifications. To warn you of this overscale situation, Coastal 
Explorer will display a yellow warning symbol next to the viewing scale in upper-left corner of each chart panel. 
When this symbol is displayed, at least one of the charts drawn on the screen is being displayed at more than 
twice its intended scale. 

To zoom in and out with the menu: 
 The View menu has a Scale sub-menu with various scale options.  

To zoom in and out with the toolbar: 
 Press the Zoom In or Zoom Out buttons, or  

 Move the Scale Slider back and forth  

To zoom in and out with the keyboard: 
 Use the + key to zoom in.  

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Quilting.htm


 

88 

 Use the - key to zoom out.  

The main keyboard + and - keys will work as will the keys on the number pad (if your keyboard has a number 
pad). When using the keys on the main keyboard, you do not need to hold down the Shift key even if the + is 
normally a shifted character. 

To zoom in and out with the mouse: 
 If your mouse has a wheel, roll the wheel up and down to zoom in and out.  
 Click the left mouse button on the chart's North arrow and select a scale from the list or use the slider in 

the popup control panel.  

To scroll and zoom with the Chart Overview panel: 
 With the left mouse button, drag the view area outline around in the Chart Overview panel to scroll.  

 While pointing the mouse cursor at the Chart Overview panel, use the mouse wheel to zoom in and out.  

REVIEW: Add the new Cruise Mode scale tool! 

Bookmark 
You can set a quick “bookmark” that lets you quickly get back to a particular chart view. Returning to the 
bookmark will restore the location, scale, and orientation that were in use when the bookmark was set. 

To bookmark an area: 
 Press the F9 key to bookmark the currently displayed area.  

To return to a bookmark: 
 Press the F10 key to return to the bookmarked area.  

 Each time you press the F10 key it will jump back and forth between the bookmarked area and the area 
you were looking at before going to the bookmark.  
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Chart Orientation 

The chart display may be rotated so that either North or the top of the chart is "up" on the screen. These 
options are available on the View > Orientation menu. (Some raster chart images are oriented such that North is 
not at the top of the screen, but vector charts are always oriented with North being up.)  

While you are navigating, two additional rotation options are available on the View > Orientation menu: Course 
Up will rotate the chart such that the active legline is pointing up, and Heading Up will rotate the chart such that 
the current heading of the boat is pointing up. 

The Course and Heading options will rotate the chart as your course or heading changes in order to keep them 
"up." 

In planning mode, the upper-left corner of the chart has a box showing the scale, an arrow indicating the 
direction of north, and the current orientation. It looks like this: 

 

You can also change the orientation by clicking on the North Arrow and selecting from the list that appears. 

REVIEW: Add the new Cruise Mode tool! 

Finally, pressing the U key will cycle the orientation between the available options. 
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Controlling the Amount of Detail You See 

The Format menu contains several commands that allow you to control how much detail is displayed on the 
chart. Vector charts provide the most control over the level of detail as they are made up of individual objects 
that can be hidden or shown based on their type. 

In Cruise Mode, the Info menu on each chart viewer provides access to these options. 

The Base, Standard, and Full Object Display commands provide quick access to three different levels of detail 
for vector charts. "base" shows the minimum set of objects necessary for planning, "standard" adds other 
objects that are necessary for safe navigation, and "full" shows everything in the chart's database that is 
intended for the chart's scale. The higher the level of detail, the more clutter you will see. 

The Vector Charts... command leads to a window for formatting the vector chart display. With it, you can 
control how symbols look, how much text is displayed on the chart, and how lights and depth information are 
displayed.  

The Text Size commands allow you to adjust the overall size of text shown on the chart. (Since raster charts are 
just an image of the paper chart that is then "stretched" to display on the computer screen, these commands 
cannot change the size of text on those charts.) 

The Chart Types commands allow you to select the types of chart to display. If you have split the chart into more 
than one panel, these commands will only affect the left-most panel.  

The Chart Colors commands allow you to change the colors of most of Coastal Explorer for use in low-light and 
night-time situations.  

The Marine Facilities, Aerial Pictures, and Chart Note Links options control the display of certain features that 
come with Digital ChartKits from Maptech other companies that produce compatible products. If you have not 
installed the appropriate features from one of these products, these options will not have any effect on the 
chart display.  

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Dlg_Format_VectorChart.htm
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Format Vector Chart Window 

Format > Vector Charts 

This window lets you control various aspects of how vector charts are displayed. 

 

The Symbols list lets you select between simplified symbols designed specifically for use on computer screens 
and more traditional symbols.  

Show Important Text Only and Show All Chart Text select between two different levels of detail for text display. 

Show Full Light Sectors controls the display of light sectors, the part of a light that indicates its estimated visible 
range. 

Show Light Descriptions controls the display of descriptions of lights. When the display is off, you can still see 
the description of a light by selecting it and looking in the property pane. 

Show Soundings controls whether or not depth soundings are displayed. 

Make Safe Soundings Dimmer controls whether or not depth soundings deeper than the safety contour are 
displayed in a color dimmer than shallow soundings. 

Show Two and Four Depth Shades control how many different colors are used to indicate water depths. 

The Safety, Shallow, and Deep Contour options control the depths that are considered "safe", "shallow", and 
"deep". These depths are used in conjunction with the number of depth shades to determine how to draw the 
water on the screen. The chart's depth contour line that is the same or deeper than the safety contour is also 
shown thicker than other contour lines.  

When the Show Two Depth Shades option is selected, any water areas that are less deep than the safety 
contour are displayed in a pale-blue color while areas that are deeper are shown in white (or black, depending 
on your chart color selection). 

When the Show Four Depth Shades option is selected, depth areas between zero and the shallow contour are 
displayed in pale-blue, areas between the shallow contour and the safety contour in a ligher pale-blue, areas 
between the safety contour and the deep contour in a very pale-blue, and finally areas deeper than the deep 
contour are displayed in white. 
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You should always set the safety contour depth to a value that you feel is safe for your boat. This allows Coastal 
Explorer to alter the colors used when drawing water areas on the chart such that safe areas are always shown 
in white, while areas that you need to be extra careful in (or stay out of) are shown in blue. 

This diagram illustrates the various contours and shades that can be adjusted: 
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Finding Places 

The toolbar has a box near its left side with a GO button next to it. This is called the Search Control. With it you 
can find places by name or location. Just click in the box (or press Ctrl+D or Alt+D to activate it), type the name 
of a place into the box and click the GO button (or press the Enter key).  

Coastal Explorer will search for places matching the name you entered and center the chart view on the first one 
it finds. If more than one place matches the name you entered, the Task Pane will show the results of your 
search. You can click on any of the places listed to show that place on the chart. You can also use the F3 key to 
select the next place in the list and the Shift+F3 key to select the previous place. 

The Search Control will not only find places from Coastal Explorer's gazetteer, but also from the Guide Books, 
tide and tidal current prediction stations, area weather forecast, your own navigation objects, even nearby ships 
if you have an AIS receiver installed. 

You can also use the Search Control to go directly to a location by entering a latitude and longitude, or to select 
a specific chart scale by entering the desired scale (as in "1:10,000"). 

Clicking the down arrow button between the search control and the GO button displays a list of the last few 
places you searched for. You can select one of these to quickly go back to one of those places. 

Find Window 
Edit > Find 

Another way of searching is to use the Find window which can be accessed by selecting Edit > Find from the 
Planning Mode menu or pressing the Ctrl+F key. Enter the name of the place you wish to find in the box at the 
top of the Find Window. As you type, a list will show you places that match what you’ve typed so far. Click on an 
entry in the list to center the chart on that place. 

 

Gazetteers 
Coastal Explorer includes an extensive gazetteer which covers the entire US as well as Canada and Mexico. 
Gazetteers for additional countries may be downloaded from the coastalexplorer.net web site. 

http://coastalexplorer.net/
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Voyage Plans 



 

96 

Voyage Plan Browser 

The Voyage Plan Browser provides you with several ways of looking at a voyage plan. Tabs along the top of the 
browser let you choose between various views including: 

Route Details This is a tabular view of a route where each row represents one leg 

Obstacles This shows a list of obstacles that have been detected along the route 

Timeline This view makes it easy to plan a departure time based on a desired arrival time as well as other 
time-related calculations 

To start the Voyage Plan Browser: 
 Click the right mouse button on the route you want to see and select the Show Route Details option or 

just double-click on route.  

To close the Voyage Plan Browser: 
 Click the X button on the right side of the top of the browser panel.  

 Or press the Esc key. (The Esc key cancels several things so you might need to press it a few times to 
close the browser panel.)  

To change the size of the Voyage Plan Browser: 
 Drag the bar that is between the Browser Panel and the Chart Viewer.  

Using the Route Details Page 
The Coastal Explorer Route Detail Viewer displays one of your routes in a tabular format along with various 
information about the route as a whole. The Route Detail Viewer can also be used to calculate an ETA for each 
waypoint along the route. 

The top part of the Route Detail Viewer displays information about the route as a whole, including the name of 
the route, when and where you intend to start navigating the route, and the total distance, estimated total time 
and estimated time of arrival. At the top-right corner of the Route Detail Viewer you will find two buttons. The 
Options button displays a menu described below, and the X may be used to close the Route Detail Viewer. 

You will typically want to use the Start using current date and time option and the Start at current boat 
location options for routes that you are about the start navigating, and the other options for routes that you are 
just planning for later. These options affect how the ETAs are calculated, and the starting location affects the 
total distance calculation as well. 

The rest of the Route Detail Viewer is a table where each row provides information about one leg-line of the 
route, including the waypoint at the end of the leg-line, the bearing to that waypoint in both True and Magnetic 
degrees, the distance to that waypoint, the total distance so far, the speed at which you expect to travel along 
the leg-line, the ETA to the next waypoint, the angle of the next turn, the ending position, and finally any notes 
you might have written about the next waypoint. 

Some of the information in the table can be edited by double clicking the mouse button on the value you want 
to change. After changing the value, press the Enter key or click outside the value to accept the new value, or 
press the Esc key to cancel the change. 

Values that can be changed include: the waypoint name, the intended speed, the waypoint position, and the 
notes. The rest of the values are being calculated by Coastal Explorer, so you cannot change them directly.  
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The Options menu provides these options: 

 Activate Route Start navigating the route  

 Reverse Route Turn the route around  

 Check Route for Obstacles Look for obstacles and other warnings along the route  

 Set Speed of All Legs... Display a window where you can specify a speed to be used for all of the legs  

 Show ETA to the Second Show or hide the seconds on all ETAs  

Using the Obstacles Page 
The Obstacles Panel searches the chart database for obstacles and warnings in the area between the boat and 
the location along the current course that the boat will be in a few minutes at the current speed. A list of 
warnings is displayed in the panel. 

This feature requires vector charts covering the area in question as there is no way to perform this kind of 
search on raster or photo charts. It also requires that you are moving and that the PC is receiving a valid GPS 
signal indicating where you are, what direction you are moving, and how fast you are moving. 

Please keep in mind that Coastal Explorer cannot predict all obstacles (things like logs and other boats usually 
aren't listed in the chart database) and that the charts you have don't necessarily contain all the known 
obstacles.  

Although you will still need to keep a vigilant watch off your bow, the Obstacles Panel can alert you to many 
things you might not see out there such as warnings, covered rocks, regulated traffic zones, and military test 
areas. 

Using the Route Timeline Page 
The Route Timeline Browser displays a route as a timeline rather than geographically. The primary use of the 
Route Timeline Browser is to estimate travel times and optimal departure times.  

The timeline browser is a horizontally oriented time-based graph. Increasing time extends to the right. The 
graph can be scrolled by dragging it with the mouse, using the Arrow Keys, or pressing the mouse button near 
the left or right edges of the graph. A calendar button provides a means to scroll directly to a particular date.  

The time scale can be changed with the plus and minus keys or similar buttons on the toolbar. The mouse wheel 
can also be used to adjust the time scale while keeping a particular point in time centered at the mouse cursor.  

The timeline browser indicates sunrise and sunset times (based on the current vessel location).  

A route is drawn as a straight horizontal line segment for each leg with gaps where waypoints have layovers. 
Each waypoints is displayed with its assigned icon (or the circle around a dot if no icon is assigned). The name of 
each waypoint is displayed in vertical text below the icon. The planned speed for each leg is displayed above the 
leg lines.  

Moving Waypoints through Time 

Waypoints can be dragged through time to see the affect being at that waypoint at that time will have on the 
rest of the route. (For now, the recalculation does not occur until you let go of the mouse button but this will be 
changed in future updates.)  

Moving the first waypoint of a route through time sets the planned departure time for the route. (Actually it's 
the planned time the vessel will be at that waypoint.) When the first waypoint is moved to a spot in time, the 
rest of the waypoints in the route are moved through time based on their respective estimated times of arrival.  
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The estimated times of arrival for each waypoint depend on:  

 Planned speed (through water)  

 Distance between waypoints  

 Current predictions (when stations have been 'attached')  

 Layover time  

When a waypoint other than the first is dragged through time, the ETA for all other waypoints will be adjusted 
as well.  

When a waypoint is moved to a new location, the ETA for it and all following waypoints will be adjusted.  

When a waypoint is added to the route, the ETA for that waypoint and all following waypoints will be adjusted.  

When a waypoint is removed from a route, the ETA for all following waypoints will be adjusted.  

Planned Speeds 

When routes are created, each leg is assigned the default cruising speed that you have entered in Boat 
Properties. This speed can be changed in the Route Details panel by double-clicking on a speed in the table and 
entering a new speed, or by clicking on the Options button and selecting Set Speed of All Legs.  

If you want Coastal Explorer to calculate the affects of currents on your route, the speeds you enter should be 
your planned speed through water (not over ground).  

In future updates, it will be possible to set the speeds from within the Route Timeline Browser.  

Attaching Current Stations 

In order to include predicted currents in the ETA calculations, you must first 'attach' current stations to legs of 
the route. This is done by right-clicking on a leg of the route and selecting the Attach Closest Current Station 
option. A dashed line will appear between the current station and the middle of the leg. When a current station 
is attached to a leg, the menu option changes to Detach Current Station so you can remove the association if 
necessary.  

This technique is only temporary and later in the beta test it will be easier to attach specific current stations and 
to have Coastal Explorer automatically choose the right current station. It will also be possible to have more 
than one station affect different portions of a leg.  

Locking Waypoints in Time 

It is possible to 'lock' a waypoint in time. This is useful when, for example, you really want to get to a pass at a 
particular slack time. When a waypoint is locked in time, adjusting other waypoints may require changing 
planned speeds. Time locked waypoints are displayed with a small padlock icon above the waypoint icon.  

When a waypoint is locked in time, moving other waypoints will cause the planned speeds to be adjusted in 
order to maintain the right time at the locked waypoint. 
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Navigation Objects 

Coastal Explorer lets you create several types of objects on the chart, including routes, marks, boundaries, and 
range/bearing lines. These are collectively called Navigation Objects and are described in detail in Help. 

You can create a new navigation object by selecting the type you want from the Insert menu. The most common 
types can also be created by clicking the appropriate button on the toolbar. 

After using an Insert command, you should click on the chart where you want the object to appear. For routes 
and boundary areas, click at each waypoint or corner that you want a waypoint or marker, and when you are 
done, click twice in the same spot. For a range/bearing line you will click once at the start of the line and once at 
the end. 

After inserting an object, you can move it around by dragging it with the mouse (routes can’t be dragged 
around, but their waypoints can). 

Each type of object has various properties that can be seen and adjusted in the Properties panel that always 
appears on the right side of the Coastal Explorer window. The Help system has all the details about each of these 
properties. 

Right-clicking on any object will display a menu of operations and options for that object. These menus are how 
you get quite a lot done in Coastal Explorer, including adding waypoints to routes, reversing routes, activating a 
particular waypoint to go to, or locking an object in place. 
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Using Documents 

Unlike chart plotters and most other navigation software, Coastal Explorer uses document files to store your 
navigation objects. This gives you a lot of flexibility in how you organize things and provides some other features 
unique to Coastal Explorer.  

The first time you started Coastal Explorer, an empty document called MyRoutes was created for you. You can 
create as many routes or other navigation objects as you like and keep them all in that document, or you can 
choose to create any number of your own documents and save them anywhere you like.  

One application of this ability is to create a new document for each major cruise you go on. The document 
would start out with one or more routes that you will follow on that trip, perhaps some boundaries that you set 
up to remind you of areas to avoid, etc. Once you are back from your trip the document will also have a track of 
everywhere you actually went. This document can then be kept in your My Documents folder (or anywhere else 
you want) in case you want to copy one of its routes or just go back and see where you were. Meanwhile, you 
can create a new document for your next trip and not have the previous trips cluttering up the chart.  

You might also start out just saving everything in one document, but decide later that you would like to organize 
things by cruising area. With Coastal Explorer, you can load the big document, drag a selection around all the 
objects in an area, use the Edit > Copy command to copy all of those objects to the Windows Clipboard, use File 
> New to create a new document, use Edit > Paste to paste the objects from the clipboard into the new 
document, and finally use File > Save As to save the new document with a name appropriate for that region.  

If you are cruising with other boats, you can share a trip's document with another Coastal Explorer user by using 
the File > Send To > Mail Recipient command. This will start your e-mail program and create a new message 
with the current document attached to it. You just have to enter the recipient's e-mail name and send the 
message. When they receive the message, they just need to open the attachment with their e-mail program and 
Coastal Explorer will start on their computer to show them the trip!  

Many people plan their trips with one computer and then use another on their boat. Coastal Explorer makes 
transferring documents to another computer easy with the other commands on the File > Send To menu. This 
menu lists each removable storage device on your computer (things like floppy disk drives and USB Flash drives). 
When you select one of these options, a copy of the currently open document is sent to the storage device 
which can then be taken to the other computer where the document can be opened with Coastal Explorer or by 
just double-clicking on its icon using the Windows Explorer.  

To Create a New Document: 
A new document is created with the File > New command. 

To Open an Existing Document: 
An existing document may be opened with the File > Open command. 

The File menu also has a list of the most recently opened documents and you can open one by selecting it from 
this list. 

When Coastal Explorer is started, it will automatically try to open the last document that was being used. If that 
document is missing (or you haven't had one open yet), a new empty document is create at start-up. 

You can use the Windows Explorer to open a document by double-clicking on its icon or by dragging the icon 
over the Coastal Explorer window and dropping it. 
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If you receive a document as an e-mail attachment, you can also use your e-mail program's Open Attachment 
command to cause Coastal Explorer to open the document. Be careful, though, as the document file will 
probably be placed in a temporary folder by the e-mail program, so you might want to use the File > Save As 
command in Coastal Explorer to save the document in a known place. 

Saving Document Files: 
A document is saved to a file with the File > Save and File > Save As commands. 

The Save command will save the document to its original file while the Save As command saves the document 
to a different file name.  

When you use the Save As command to save to a different file, you are essentially switching over to that new 
document. In other words, if you open a document called "one" and then save it as "two" then you are now 
using the document called "two" and "one" remains unchanged in its original file. 

The Send To commands provide an alternative to using Save As when what you really want is a copy of the 
current document on a floppy disk or other removable storage device in order to take it to another computer. 
The Send To commands save a document file with the same name as the one that is open, but on a different 
drive. After the Send To command, you are still using the original document. 

The File > Export command provides a way to save part of the current document to a new file which can either 
be a Coastal Explorer document, or some other file format for use with other programs. 

Send To 
The Send To commands may be used to send the current navigation object document to another computer as 
an email attachment, or to a removable storage device such as a floppy disk or a USB flash drive. 

To send the current document as an email attachment:  
 Select the File > Send To > Mail Recipient command. Your email program will appear and display a 

message window already setup with the attachment. You can enter a message and then send just like 
any other piece of email.  

To send the current document to a floppy disk or other removable storage device:  
 Select the destination from the File > Send To menu. The document is saved in the root folder of the 

destination and has the same name as the current document. If a file with that name already exists in 
the destination, you will be asked if you want to overwrite it.  

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/SendTo.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Export.htm
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The Clipboard (Cut, Copy, and Paste) 

Like most Windows applications, Coastal Explorer makes use of the Windows Clipboard to transfer objects from 
one place to another using standard Cut, Copy, and Paste commands. 

The Clipboard is a temporary place to keep objects of just about any type. When you cut an object, it is moved 
to the clipboard and copying an object leaves the original alone but places a copy of it in the clipboard. Paste 
copies the contents of the clipboard to the current document. 

Coastal Explorer lets you select more than one object at a time so you can move or copy a group of objects with 
one Cut/Copy and Paste operation. 

To move or copy and object from one document to another: 
1. Open the document that has the object you want to move or copy.  
2. Select the object that you want to move or copy.  
3. Use the Edit > Cut or Edit > Copy command.  
4. Open or create the document you want to move or copy the object to  
5. Use the Edit > Paste command.  

To select more than one object at a time: 
1. Select the first object by clicking on it  
2. Select additional objects by clicking on them while holding down the Ctrl key 

Or: 

1. Drag a selection rectangle around a group of objects using the Select Tool.  

NOTE: When you copy an area, the clipboard end up with a copy of each object within that area as you would 
expect, but it will also contain an image of the selected area that can be pasted into an image painting program, 
word processing document, or even an e-mail message. You will also get an image of the visible area of the chart 
if you use the copy command when nothing is selected. 
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Creating a Route 

To create a new route: 
2. Click the Add Route button on the Navigation Object toolbar, or select Route from the Insert menu, or 

press the F8 key to begin the route creation mode.  
3. Click on the chart where you would like the route to start; this will set the location of the first waypoint.  
4. Continue clicking on the chart to add additional waypoints.  
5. When you have added all the waypoints you want, click the last one again to end route creation mode.  

While you are in route creation mode, the mouse cursor will gain a small plus sign to indicate that you will add a 
waypoint when you click. Near the edges of the chart, however, the mouse cursor will show a large arrow 
pointing outward from the chart to indicate that you are in the automatic scrolling zone. You cannot create 
objects in the automatic scrolling zone, but moving the mouse there will scroll the chart so that you can get the 
waypoint where you want it. 

If you click on an existing mark while creating a route, Coastal Explorer will ask if you want to "Reuse the existing 
mark." Answering Yes to this question causes the route you are creating to use the mark that is already there as 
the next waypoint, sharing it with any other routes that might be using it too. Answering No causes a new mark 
to be created at the same location. The difference is that moving, deleting, or otherwise changing a shared mark 
will affect all of the routes that are sharing it, while changing a mark that is not shared will only affect the route 
that uses it. 

You can avoid the "Reuse the existing mark" question by holding down the Ctrl key when you click to add a 
waypoint; holding down Ctrl will cause the mark to be reused.  

After you have created the first waypoint, a line will be drawn between the last waypoint and the mouse cursor. 
This line represents the leg-line that you are about to create. The line will normally appear in black, but if Coastal 
Explorer detects an obstacle along the leg-line, the line will appear in red. A yellow line indicates there is 
something other than an obstacle along the leg-line that you should be aware of such as a ferry route. In some 
cases, a yellow bubble will point out the problem on the chart, but in any case you can check the property 
viewing area for a list of obstacles and other issues having to do with the leg-line you are creating. 

In addition to the leg-line that follows the mouse cursor, you will see a dashed purple T-shape that extends from 
the leg-line to the edge of the chart and also perpendicular to the leg-line in both directions. This cross hair is 
there to help you line up your new waypoint with other objects or locations on the chart. 

Finally, the distance and bearing of the leg-line is also displayed near the mouse cursor. 

To create a new route that starts the same as another route: 
It is very common to have multiple routes that all start with the same few waypoints. You might keep your boat 
at a particular place which requires a few waypoints to get out of and then head in any of several directions 
when you ge out, for example. Coastal Explorer has a feature that helps create this kind of route. 

The Fork Route option, which is found on the menu for marks that are used in a route, will create a new route 
that starts out with a copy of each of the waypoints leading up to, and including, the mark that you clicked on to 
select the fork route command. The end result is the same as if you started creating a new route and then 
clicked on the first few waypoints of another route and answered Yes to the question about reusing the existing 
mark.  

To use the Fork Route option, click the right mouse button on the waypoint that you want to start the fork at 
and select Fork Route.  
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To quickly create a new route with only one waypoint: 
With the Instant Route option you can create a route with a single leg-line that starts at your current location. 
This can be very handy if you are crusing around without a route and want to quickly start using your autopilot 
or Coastal Explorer's route following features.  

To create an Instant Route: 

1. Select the Instant Route option from the Insert menu, or if you are in Cruise Mode, select the Instant 
Route button on the Function Bar. A mark will be added at the boat's current location and you will be in 
route creation mode ready to add the waypoint.  

2. Click at the point in the chart where you would like the waypoint. The waypoint mark will appear and 
the route you just created will be activated.  

A route created as an Instant Route is just like any other route, so you can perform all the same operations on it, 
including adding more waypoints to the end. 



 

Coastal Explorer Reference  105 

Manipulating Routes 

Any of these route operations may be performed by clicking the right mouse button on a leg-line of the route 
and selecting the appropriate option from the menu that appears. Some of them might also appear in other 
places for your convenience, but they will always work the same regardless of how you select them. 

Locking a route against changes 
The Lock Route Position option will prevent a route from being moved. Routes have their positions locked by 
default, but may be unlocked in order to drag the entire route to a new location. 

The Unlock Route Position option will allow a route to be moved. 

Activating a route 
The Activate Route option will start navigation along the route. The first waypoint of the route is selected as the 
current target and Coastal Explorer will start issuing instructions to you and optionally your autopilot in order to 
get your boat there. 

The Deactivate Route option will stop all navigation instructions. 

Reversing a route 
The Reverse Route option will turn a route around so that the end becomes the start and vice-versa. 

Splitting a route in two 
The Split Route option will turn the route into two routes by removing the leg-line that you clicked on to get the 
route menu. 

Adding waypoints to the end of a route 
The Add to end of route option will re-enter route creation mode to let you add more waypoints to the end of 
the route. 

Inserting waypoints into a route 
The Insert new mark option will insert a new mark at the point along the leg-line that you clicked to get the 
menu. 

Removing waypoints from a route 
To remove a waypoint from a route, select the waypoint's mark and press the Delete key. 

Sending a route to your GPS or Chartplotter 
The Send to GPS option will let you send (upload) a route (or several routes if more than one is selcted) to your 
GPS or chartplotter. 

View or changes the properties and options of a route 
Right-click on the route and select Properties. 
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Route Properties 
A route's properties may be viewed or changed with the Properties Task Pane when the route is selected. The 
properties of routes are: 

General Properties 

 Name The name of the route. If you do not supply a name, Coastal Explorer will make one up based on 
the starting and ending waypoints of the route. The made up name will then be used everywhere that a 
route's name would normally be shown, except in the property panel.  

 Waypoint Style Controls how turns at waypoints are displayed. The options are Arrival Circle which is 
the default and shows each waypoint as a hard turn with an arrival circle around it, Wheel Over Line 
which uses your boat's turning radius to determine where you should start turning in order to get to the 
next leg, and Predicted Log Race which also uses your boat's turning radius, but assumes you don't want 
to start turning until you reach the waypoint. See below for more information about these styles. 

 Direction Arrows Controls the display of arrows point in the direction of travel at the end of each leg-
line.  

 Display Leg Range/Bearing Controls the display of the range and bearing values of each leg-line.  
 Total Length The total length of the route (this value may not be changed).  

Format Properties 

 Color The color to display leg-lines when no route is active.  
 Active Color The color to display leg-lines when the route is active.  
 Inactive Color The color to display leg-lines when some other route is active.  

Notes Properties 

 Description An optional description or other notes about this route.  

Leg Line Properties 
A leg line's properties may be viewed or changed with the Route Details Panel when the leg-line is selected in 
the table. The properties of leg lines are: 

 Speed The speed at which you intend to run the leg. This is set to your boat's cruising speed by default.  

Waypoint Properties 
A waypoint's properties may be viewed or changed with the Properties Task Pane when the waypoint is 
selected. The properties of waypoints are: 

General Properties 

 Name The name of the waypoint.  
 Show Name Whether or not to show the waypoint's name on the chart.  
 Color The color used to draw the name.  
 Icon The icon to show at the waypoint.  
 Position The latitude and longitude of the waypoint.  
 Lock Position Controls whether or not the waypoint may be moved.  
 Arrival Circle Radius Controls how close the boat must get to the waypoint in order to have arrived.  
 Layover Time How much time you intend to stay at this waypoint before proceeding to the next. This 

time will affect the ETA calculation and is useful for fuel and lunch stops.  
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Notes Properties 

 Show Description Controls whether or not the description is shown on the chart.  
 Description An optional description or other notes about this waypoint.  

About Waypoint Styles 
Coastal Explorer provides you with several different styles of waypoint. Normally you will leave this set to the 
default value of Arrival Circle, but the other styles are very useful in certain circumstances. Here is a diagram 
showing how the different styles appear: 

 

Arrival Circle -- This is how most navigation programs, chart plotters, and auto-pilots work, at least in the 
recreational world. Basically a route is a sequence of waypoints and the vessel is supposed to follow the route 
by moving from waypoint to the next along the leg-lines formed between each pair of waypoints. When a vessel 
enters the "arrival circle" surrounding a waypoint, or passes a line bisecting the angle between two leg lines, the 
vessel has "reached" the waypoint and the next waypoint is selected or the route is completed. In Coastal 
Explorer, these waypoints are displayed as a circle that represents the "arrival circle" and a line representing the 
"passing line". 

Wheel Over Line -- This is a feature of many non-recreational navigation systems and more correctly models 
how a vessel will travel through the water when following a route. In this mode, the radius of the turn that must 
be made to get from one leg to the next is considered. Then a "wheel over line" is displayed at the point along 
each leg when the turn should be started. (The wheel over line is a short line perpendicular to the leg-line at the 
point the turn should begin.) In Coastal Explorer, the predicted turn (based on the turning radius and angle 
between the leg-lines) is shown as a dashed curve starting at the wheel over line. 

Predicted Log Race -- This feature is exclusive to Coastal Explorer and is intended for predicted log racers. If you 
don't know what predicted log racing is, then it probably won't make any sense to you! (See the North American 
Cruiser Association website, www.predictedlog.org, for information about log racing.) In a nutshell, a predicted 
log race is a form of precision navigation oriented "race" for slow powerboats. In one of these races, the skipper 
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always strives to precisely reach each waypoint and then turn as quickly as possible to head towards the next. 
During the turn, a certain amount is "slide" is inevitable. The Predicted Log Race waypoint style uses your 
turning radius to predict this slide and adjusts the following leg line to show the turn and the bearing from the 
end of the turn to the next waypoint (rather than the bearing from the first waypoint to the next). 

It is important to realize that the ONLY waypoint style that makes sense when using an auto-pilot is the "arrival 
circle" style since that is how auto-pilots interpret a waypoint. 
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Using Marks, Annotations, Waypoints, and 
Events 

Marks, Annotations, Waypoints, and Events all behave the same but are created a little bit differently. Marks 
show up as a small icon with a name underneath, annotations are just marks without icons, and events are 
marks that are always created at the boat's location and with a name that describes when then event was 
created. Waypoints are marks that are created when you are creating a Route. 

The operations that you can perform are all the same for marks, annotations, waypoints, and events. They are 
available by clicking the right mouse button on the mark. 

Lock Mark Position - Prevents the mark from being moved. 

Unlock Mark Position - Allows the mark to be moved (unless the mark belongs to a route which is locked). 

Hide Mark - Hides the mark on the chart (the mark will remain visible as long as it is selected). You can show 
hidden marks and other objects using the Navigation Object Browser.  

Activate Waypoint - Navigate to the mark. 

Show Name - Shows or hides the name of the mark. 

Show Description - Shows or hides the description of the mark. 

Delete Mark - Delete the mark. 

The properties that can be seen or changed in the Property Panel are: 

General Properties 

 Name The name of the mark.  

 Show Name Whether or not to show the name on the chart.  

 Color The color to use for the name and description text.  

 Icon The symbol to use for the mark on the chart.  

 Position The latitude and longitude of the mark.  

 Locked Whether or not the mark is locked against changes.  

 Arrival Circle Radius How close to the mark the boat must be to have arrived at the waypoint.  

 Boundary Circle Off Limits Used to turn a mark into a Boundary Circle. When this is set to Inside, an 
alarm will sound when the boat enters the arrival circle, and when it is set to Outside, an alarm sounds 
when the boat leaves the arrival circle.  

Range Properties 

The range properties control the display of range circles which are circles that may be drawn around the mark at 
regular distances you specify. They are only used as a visual indicator to you, and should not be confused with 
the Arrival Circle which is used to determine arrival at a waypoint, or the radius of a Boundary Circle. 

 Display Count How many range circles to draw around the mark.  
 Radius How far out each range circle is drawn.  
 Line Thickness How thick should the circle appear.  
 Color The color of the circles.  
 Fill Whether the circles should be filled or not.  

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/NavObjBrowser.htm
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Notes Properties 

 Show Description Whether or not the description should be shown on the chart.  
 Description An optional description or other notes about this route.  
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Using Boundary Circles and Areas 

An alarm is sounded when the boat crosses the edge of a boundary. Boundaries may be defined as a circle, a 
series of lines, or an enclosed area. 

To create a boundary circle: 

1. Select the Boundary Circle option on the Insert menu, or click on the Add Boundary Circle button on the 
toolbar.  

2. Click on the chart where you want the boundary circle to be centered.  
3. Drag the edge of the circle with the left mouse button to adjust the size, or enter a size in the Arrival 

Circle Radius property.  
4. Select whether the alarm should sound when the boat goes Inside the circle or Outside the circle using 

the Boundary Circle Off Limits property.  

Once created, a boundary circle is really just a mark with the right properties set up. See Using Marks for a 
description of those properties and the operations that can be performed on these objects.  

To create a boundary area: 

1. Select the Boundary Area option on the Insert menu, or click on the Add Boundary Area toolbar button.  
2. Click on the chart at each point of your area or series of lines.  
3. Click again on the last point when you are done.  

A boundary area's properties may be viewed or changed with the Property Panel. The properties are: 

General Properties 

 Name The name of the boundary area.  
 Display Leg Range/Bearing Controls the display of the range and bearing values of each line of the 

boundary.  
 Color Controls the color of the of the boundary lines.  
 Fill Area Controls whether or not the boundary area should be filled in with the selected line color.  

Notes Properties 

 Description An optional description or other notes about this RBL.  

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/UsingMarks.htm
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Using Range/Bearing Lines 

Range/Bearing Lines, or RBL's, are lines drawn on the chart between two points with the range and bearing 
between the lines drawn at the line. RBL's can be between two arbitrary points, or one of the points can be the 
boat, in which case the range and bearing are continuously updated on the chart as the boat moves. 

These operations can be performed on an RBL by clicking the right mouse button on the RBL and selecting the 
appropriate option: 

Lock Range/Bearing Line - Prevents the RBL from being moved or changed. 

Unlock Range/Bearing Line - Allows the RBL to be moved or changed. 

Reverse Range/Bearing Line - Changes the direction of the RBL. 

Delete Range/Bearing Line - Delete the RBL. 

An RBL's properties may be viewed or changed with the Property Panel. The properties of an RBL are: 

General Properties 

 Name The name of the RBL.  

Notes Properties 

 Description An optional description or other notes about this RBL.  
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Navigation Object Browser 

REVIEW: Need a picture! 

While your Navigation Objects typically show up on the chart, Coastal Explorer includes another way to look at 
them called the Navigation Object Browser which you can access via the Tools menu or the Toolbar. The 
Navigation Object Browser appears below the chart and shows you a list of whatever type of navigation object 
you choose. 

Selecting an object in the Navigation Object Browser will cause the chart to scroll to show that object, and vice 
versa. You can access a Navigation Object’s menu by right-clicking on the object in the Browser or on the chart. 

You can select more than one object at a time in the Browser by using the Ctrl key while clicking on an object to 
add it to or remove it from the selection or by using the Shift key along with the Arrow, Page Up, Page Down, 
Home, or End keys. 

Each object in the browser has a check box that you can use to hide or show the object. 
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Exporting Navigation Objects 

File > Export 

This window lets you "export" navigation objects to a file that can later be inserted into another navigation 
object document, imported by some other program, or just kept as a backup. 

You get to the Export window with the File > Export command. 

 

The window displays a list of all of the navigation objects in the currently open document. You can sort the list 
by the type or name of the object by clicking on the header for the column you want to sort by. 

Each navigation object has a check box next to it which indicates which objects you want to export; just click the 
box to check or uncheck an object. You can select multiple objects using the Ctrl or Shift keys and then check or 
uncheck all of them at once. Buttons are provided to check or uncheck all of the objects as well. 

Once you have selected the objects to export, click the Next > button. This will lead you to another window 
asking for the name and type of the file to create. 

You can choose to create a "Navigation Object File" which is Coastal Explorer's own format and will contain 
exact copies of the selected objects, or one of several other formats for use with other programs. Because of 
limitations in the various file formats, some properties of your objects may not be saved, but most of the really 
important ones usually are. 

The formats for other programs that can be exported include: 

 OpenNav which is compatible with navigation software from Jeppesen Marine (Nobeltec®).  

 RXF which is the format used by several of Maptech's chart programs for routes.  

 MXF which is the format used by several of Maptech's chart programs for marks.  

 GPX which is an open standard format used by many other programs.  

 KML which is the format used by Google Earth™.  

The File > Send To feature is similar to exporting, but always creates a navigation object file containing all of the 
objects from the open document. It is useful for instantly sending a copy of the current document to someone 
with e-mail, or to another computer with a floppy disk or other removable storage device. 

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/SendTo.htm
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Send to GPS Window 

This window lets you send one or more routes and/or waypoints to your GPS or chartplotter. Coastal Explorer is 
capable of sending routes and waypoints to most GPS/chartplotter models that accept the standard NMEA 0183 
RTE and WPL sentences as well as proprietary methods used by Furuno, Garmin, Lowrance, Magellan, and 
Northstar. Not all GPS and chartplotter equipment supports the ability to receive routes or waypoints, and many 
of them have limitations. Please refer to the user guide for your GPS or chartplotter to see what its limitations 
are.  

To send a route or waypoint to your GPS/chartplotter: 
1. Right-click on the route or waypoint you want to send and select the Send to GPS option from the 

popup menu.  
2. Select the type of GPS from the list labeled To.  
3. Select the port the GPS is connected to from the list labeled On.  
4. Press the Start button.  

Special notes for users of Garmin GPS units and Chartplotters 
Most Garmin products can be configured to operate using one of two "protocols"; either NMEA 0183 or a 
proprietary Garmin protocol. Coastal Explorer can use either protocol, but must be configured to use the same 
protocol as the Garmin device. This can be done with either the Tools > Options > Instruments > Auto Detect 
feature, or with the Tools > Options > Instruments > Port Settings feature. Refer to your Garmin user guide for 
information on how to select which protocol (or "Transfer Interface") your Garmin device will use. 

Some Garmin devices require you to use the Garmin Transfer Interface when sending routes or waypoints to 
them. Others will work in either mode. This is not always mentioned in the user guides, so please keep this in 
mind when trying to use this feature in Coastal Explorer. 

Special notes for users of Furuno GPS units and Chartplotters 
Sending one or more navigation objects to most Furuno equipment will cause the equipment to erase all other 
routes and waypoints from its memory. If you have data that you don’t want to lose saved on Furuno 
equipment, you should import all of it to make a backup file before sending a route or waypoint. 
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Importing Navigation Objects from Other 
Programs 

REVIEW: This should be merged with the chapter about the Import command. The Insert File command should 
be considered a “shortcut” method. 

Coastal Explorer can import routes, waypoints, and other navigation objects that were exported from some 
other programs. Importing a file will insert the navigation objects found in that file into the current document. 

The file formats that are supported include: 

 Navigation Object Files These files have the .NOB file type and are Coastal Explorer's normal document 
file format. These files may be exported from Coastal Explorer, or you can import a Coastal Explorer 
document file which will merge that document's navigation objects into the currently open document. 
Chart Navigator Pro from Maptech also uses the .NOB document file format.  

 Maptech Navigator Export Files These files may be exported by Maptech's Chart Navigator and Offshore 
Navigator programs. Coastal Explorer can import Routes, Marks, and Named Waypoints from files called 
Routes32.txt, Marks32.txt, and Nwps32.txt respectively. These are the only files that the Maptech 
products will export these objects to.  

 Maptech Outdoor Navigator Files These files may be exported by Maptech’s Outdoor Navigator 
program. 

 Maptech Terrain Navigator Files These files may be exported by Maptech’s Terrain Navigator program. 

 Open Navigation Format These files may be exported from Jeppesen Marine’s (Nobeltec) VNS and 
Admiral products. Coastal Explorer can import all of the objects from the Open Navigation Format 1.1 
specification which includes Marks, Routes, Tracks, Boundaries, and Range/Bearing Lines. Please contact 
Jeppesen Marine for more information on this file format.  

 The Capn Database Files These files may be exported from The Capn by Nautical Technologies. Coastal 
Explorer can import route and waypoint files that have been exported by The Capn 5.0 and later.  

 NMEA Waypoint List Files This is not a formal file format, but some programs (including The Capn' from 
Nautical Technologies) are capable of exporting these files which are simply a list of NMEA waypoint 
location sentences. Each one of these files contains a single route which is made up of the waypoints 
described in the file.  

 Lowrance USR Files These files are used by some Lowrance GPS receivers and are typically stored on 
Flash Memory cards that can be moved between the GPS and your PC. 

 Magellan eXplorist Files These files are used by the Magellan eXplorist line of hand-held GPS receivers. 

 GPX Files This is an “open standard” file format that is used by many other programs. 

To import navigation objects into Coastal Explorer: 
1. Select Insert > Navigation Object File  
2. Use the window to find the file you want to import and click OK.  
3. Coastal Explorer will determine the type of the file you selected, import the objects, and let you know 

what it found. You will also be given the chance to select all of the objects that were just inserted into 
your document. 

Or: 
1. Select File > Import 
2. Choose the source you want to import from and press Next 
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If you find that you really didn't want to perform an import after it is done, you can use the Edit > Undo 
command to undo the entire import command.  

To export a route from some other program: 
Every program works a little differently, so please refer to the documentation that came with the other program 
to learn how to use it to export navigation objects. 
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Importing Navigation Objects from a GPS or 
Chart Plotter 

Coastal Explorer can import routes, waypoints, and sometimes other navigation objects from many different 
kinds of GPS and chart plotters. Importing will insert the navigation objects found on the device into the current 
document. 

To import objects from your GPS or chart plotter: 
 Use the File > Import command  

 Select the My GPS or Chartplotter option and click Next  

 Select the type of GPS or chart plotter from the From list  
 Select the port it is connect to from the On list  

 Check the Import Routes, Marks, and Tracks options based on what you want to import  

 Click the Next button  

 Follow any additional instructions on the screen  

Manufacturer and Model Specific Notes 
Because the NMEA 0183 standard for transferring routes and waypoints is rather limiting, many manufacturers 
have implemented proprietary methods for performing these tasks. Coastal Explorer supports several of these 
methods and the general capabilities are listed below. 

Furuno 
Furuno GPS receivers and chart plotters use extensions to the NMEA 0183 standard in order to perform route 
and waypoint transfers. (Tracks cannot be transferred to or from a Furuno.) 

When importing from a Furuno, you will need to use the Furuno device's menus to initiate the transfer. Exactly 
how to do this is covered in your Furuno manual. 

Garmin 
Garmin GPS products use a proprietary protocol called "Garmin Transfer Interface" in order to transfer routes, 
waypoints, and tracks. A Garmin GPS must be configured through its menus to use the Garmin Transfer Interface 
and Coastal Explorer must also be configured to use the "Garmin" Interface in Tools > Options > Instruments > 
Port Settings before a transfer can take place. 

Some Garmin products offer several sub-modes of the Garmin Transfer Interface. The correct mode to select is 
"Host Mode". 

Coastal Explorer is capable of receiving GPS position information from a Garmin GPS while it is in Garmin 
Transfer Mode, so it is possible to just use this mode and not switch back and forth between Garmin Transfer 
Mode and NMEA 0183 Mode. However, Garmin's combination GPS and Fish Finder products will only send 
depth information when they are configured to use NMEA 0183. 

Other Devices 
Several other proprietary interfaces are also supported, including Eagle, Lowrance, Magellan, and Northstar. 
Most of these transfers are started automatically when using the Import command. 

Many manufactures stick to the NMEA 0183 standard for transferring objects to and from their equipment so 
they are also supported. The standard does not provide a way to initiate a transfer, so you must use the menus 
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on these devices to get things started once you get to the last step in the Import command. Please refer to your 
equipment's manual for instructions on how to start the transfer. 

Import Navigation Objects Window 
File > Import 

This window lets you "import" navigation objects from a file created by Coastal Explorer or another program, or 
from a GPS or chart plotter. 

 

To import navigation objects: 
 Select the File > Import option  

 Select the source of the objects you want to import  

 Press the Next button and follow the on-screen instructions  

Resolving Merge Conflicts 
If a navigation object is copied from one document to another, then modified in one of the documents, and 
finally imported into the other document, a “merge conflict” occurs and you are presented with a window that 
shows the difference between the two objects and asks what you want to do. Your options are to: 

 Keep both objects 

 Keep only the object being imported 

 Keep only the object already in the document 
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Navigation 
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Using your Virtual Boat 

When your position is known from a GPS, Coastal Explorer will draw your boat on top of the chart. This is what 
your boat will look like: 

 

The icon in the center represents your boat and will show its location and heading (or course if the heading is 
not known). 

The solid circle around the boat is a range circle which indicates a specified distance from the boat. This circle 
may be adjusted with the boat's property panel. 

A magnetic compass rose appears around the boat with lines emanating to the edge of the screen every thirty 
degrees. These lines are intended to help you match up visual bearing with objects on the chart. 

When the boat is moving, a dashed line called the predictor will appear between the boat and the point on the 
current course that is a few minutes ahead at the current speed. The amount of time may be adjusted with the 
boat's property panel. 

A red track line will also appear where your boat has been. The track line may be configured to track a new point 
based on a time, distance, and/or heading change. You can access the tracking options by selecting the track line 
and using the Properties Panel. 

To enable the boat and move it somewhere without a GPS 
You can move the boat to any location on the chart when you don't have a GPS connected by using the Move 
Boat Here option which may be found on the right-mouse button menu of a chart. These actions initialize Dead 
Reckoning mode. 

Changing the properties of your virtual boat 
Your boat's properties may be viewed or changed with the Property Panel when the boat is selected. The 
properties of the boat are: 

General Properties 

 Position  
 Color  
 Locked  
 Display Line to Active Mark  
 Display Compass  
 Display Predictor Line  
 Predictor Time  
 Predictor Color  

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/DeadReckoning.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/DeadReckoning.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/DeadReckoning.htm
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Boat Properties 

 Name  
 Make Model  
 Registration  
 Length Overall  
 Beam  
 Draft  
 Bridge Clearance  
 Cruising Speed  

Range Properties 

 Display Count  
 Radius  
 Pen Width  
 Color  
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Dead Reckoning 

You can use Coastal Explorer in "Dead Reckoning" mode to move your Virtual Boat on the chart without the help 
of a GPS. This may be necessary if you have lost the ability to use your GPS, and it can be handy while learning 
how to use the program. 

To Start Dead Reckoning Mode: 
 Right-click on the boat symbol and select the Dead Reckoning option.  

 Right-click on the chart and select the Move Boat Here option.  

 Drag the boat to a different location on the chart.  

 Use any of the Ctrl+Shift+Arrow Keys as described below.  

Basically, any action that you take to move the boat symbol will initiate Dead Reckoning mode. 

While Coastal Explorer is in Dead Reckoning mode, the far right side of the status bar will flash "DEAD 
RECKONING". If a valid GPS fix is available, an alert will also appear in the upper-right corner of the primary chart 
to let you know that Dead Reckoning mode is active and that the GPS is being ignored. In Cruise Mode, the GPS 
Status Indicator at the top of the screen will also show "DR" under the strength meter (which will indicate no 
signal) and a yellow bar will flash above the strength indicator. 

To resume using the GPS position: 
 Right-click on the boat symbol and selec the Use GPS Position option.  

 Click on the status bar where "DEAD RECKONING" is flashing.  

 Click on the "Dead Reckoning" alert on the chart.  

The Ctrl+Shift+Left and Right Arrow Keys will steer your boat and the Ctrl+Shift+Up and Down Arrow Keys will 
speed it up and slow it down. 
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Navigating a Route 

Once you have created a route, looked up unfamiliar areas in the guide books, and double checked for obstacles 
and other hazards, you are ready to navigate. This section describes the process and tools Coastal Explorer 
provides to help you with this. 

First, use the Activate Route... command on the Tools menu to select the route you would like to follow, or 
right-click somewhere along the route and select Activate Route from the popup menu. 

Start your boat heading towards the first waypoint and Cruise Mode will become activated automatically. Or 
press F12 to activate Cruise Mode manually. 

Watch your heading and cross track error and steer appropriately. Coastal Explorer provides you with several 
tools to determine how far off course you are and which way you should steer. 

In the chart viewing area, you will see your boat with a line between it and the active waypoint. If your cross-
track-error is getting a bit large, you will see a small red arrow next to your boat indicating which direction you 
should steer to get closer to your intended track. 

If you have selected the Navigation Compass Instrument Panel, it will show you a big orange arrow pointing in 
the direction of the active waypoint. The Course Overview Instrument Panel will show your route relative to 
your boat's position and course as well as a line between your boat and the active waypoint. It will also help you 
gauge your cross-track-error. 

When you arrive at a waypoint, you will hear an alert and be given the bearing to the next waypoint. Waypoint 
arrival is determined by your boat entering the active waypoint's arrival circle, the radius of which is set with the 
waypoint mark's property pages, or by crossing the line through the waypoint and perpendicular to the leg line. 

If you are off course and decide to go directly to the next waypoint without reaching either of these conditions, 
you can press the Next Waypoint button on the Function Bar to activate the next waypoint. 

If your cross-track-error gets large enough to start causing alerts, but you decide to head directly to the active 
waypoint without getting back on course, you may press the Reset XTE button on the Function Bar. This will tell 
Coastal Explorer to reset the intended track to be from your current location to the active waypoint and the 
alerts will stop. 

When you arrive at the end of the route, you will hear an alert and the route will be deactivated. You can return 
to Planning mode by selecting Planning Mode on the Function Bar (you may have to press the More button to 
see the Planning Mode command). 
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Activate Route Window 

Tools > Activate Route 

This window displays all of your routes and let you select one to activate for navigation. 

 

You can also activate a route by right-clicking on the route and selecting the Activate Route option from the 
menu. 

When you activate a route Coastal Explorer will normally activate the first waypoint of that route. However, it 
will try to determine if you’ve already passed some waypoints, in which case it will activate the first waypoint 
that hasn’t been passed.  

As long as a waypoint is active, Coastal Explorer will send information about that waypoint to your autopilot if 
one is configured. 

A waypoint can be activated for navigation by right-clicking on the waypoint and selecting the Activate 
Waypoint option from the menu. This command does not activate a route, so once that waypoint is reached, 
navigation is complete. However, if a route is already active, you can use this command to select a particular 
waypoint from that route and in that case, the route remains active. 

When a route is active, you can activate the next waypoint by pressing the W key or the previous waypoint by 
pressing the Shift+W key. This is useful if you decide to skip a waypoint. 
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Using Tracking 

A Track is a Navigation Object that shows a line where your boat has been. Like all other Navigation Objects, 
Tracks are stored in the currently open document. 

Tracking works by recording your position at certain intervals and then connecting those positions to make the 
track line. You can decide to record a position based on a time interval, an amount of distance travelled since 
the last point, an amount of course change since the last point, or a combination of these factors. 

NOTE: Take care when deciding how to record your track as they can slow down Coastal Explorer or use a lot of 
disk space if they become too detailed! 

To enable or disable tracking: 
 Use the Tools > Enable Tracking command.  

 In Cruise Mode, click on the GPS Status Indicator at the top of the screen and select the Enable Tracking 
option.  

To start a new track: 
 Use the Tools > Start New Track command.  
 In Cruise Mode, click on the GPS Status Indicator at the top of the screen and select the Start New Track 

option.  

To convert a track to a route: 
 Click the right mouse button on the track.  

 Select the Convert Track to Route option.  

Changing the properties of a Track 
A track's properties may be viewed or changed with the Property Panel when the track is selected. These 
properties determine when track points are added to the track. Changes you make to these properties will only 
affect the active track. The properties of a track are: 

General Properties 

 Name The name of the track. This is set to the date and time the track was started, but you can change 
it.  

 Total Length The total distance travelled along this track.  
 Tracking - By Time Interval Indicates that a new point should be added to the track based on ellapsed 

time.  
 Tracking - Time Interval How much time to wait between each track point. (Only used if the above 

option is checked.)  
 Tracking - By Distance Interval Indicates that a new point should be added to the track based on 

distance traveled.  
 Tracking - Distance Interval How much distance should be between each track point. (Only used if the 

above option is checked.)  
 Tracking - By Course Change Indicates that a new point should be added to the track based on course 

changes.  
 Tracking - Degrees How much of a course change should be between each track point. (Only used if the 

above option is checked.)  
 Wake - Enable Wake When this option is on, only a portion of the track is actually shown on the chart.  
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 Wake - Length The amount of time from the track that should be represented on the chart. (Only used if 
the above option is checked.)  

Format Properties 

 Color The color to draw the track with.  
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Video 
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Video Overview 

Coastal Explorer can display the image from video cameras connected to your PC. It is possible to use "webcam" 
style cameras that typically connect to a USB port, a network video camera, or a standard video camera 
connected to a video interface device (USB or internal) on your PC.  

Coastal Explorer will let you select a source from all of the cameras currently connected to your PC and display 
the video in either a small Virtual Instrument Panel in the Task Pane or in a larger view alongside your charts.  

Video Views 
To display video instead of a chart in the main screen area, first split the screen into more than one view (use 
the 1, 2, 3, or 4 keys), then right-click on a chart panel (other than the Primary Chart View) and select the Video 
option from the menu that appears.  

The Source button below the video panel lets you select the video source. Clicking this button displays a menu 
of all of the live video sources available on your computer as well as options to open a file or network stream.  

Selecting Open Video File will cause a standard file selection window to appear so you can select a video file to 
play.  

Selecting Open Network Stream will display a window prompting you for the network address of the video 
stream you want to display.  

The rest of the options on the source menu represent the various video sources available on your computer. 
Selecting one will switch the video panel to that source.  

Video Instrument Panels 
To display video in a Virtual Instrument Panel, open the Instruments Task Pane, right-click on the Instruments 
Task Pane and select the Add another panel option, select Video from the list of data items, and press OK.  

Right-click on the Video Instrument Panel to access its options which will include the video source, any options 
provided by the video camera, and playback controls.  



 

Coastal Explorer Reference  131 

Radar 
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Radar Overview 

If you have the optional Rose Point Radar add-on module, the right-click menu for charts has a new option: 
Radar Overlay. Enable this option to overlay the radar image on the chart in that view.  

You can also split the window into more than one view and then change one of the views to show a radar image 
without being overlaid on a chart. (This cannot be done to the chart view on the right because it is the Primary 
Chart View and cannot be changed.)  

To set up a radar-only view, use the 2 or 3 key to split the screen, right click on one of the charts that appears on 
the left side of the screen, and select the Radar option from the menu. 

Radar Controls 

 

When the Rose Point Radar option has been installed, extra controls appear on the Cruise Mode toolbar at the 
top of the screen. This subpanel contains a radar Transmit/Standby button and, when the radar is transmitting, a 
radar status/control button. 

The Transmit/Standy Button indicates the current status of the radar transmitter which can be:  

OFF - This indicates that Coastal Explorer has not detected the radar on the network which could mean 
that the radar does not have power or that the network is not configured correctly.  

Warm Up - This indicates that the radar is warming up and cannot be used yet. A countdown timer will 
indicate how much time is needed to finish warming up (in 5-second intervals).  

Standby - This indicates that the radar is ready to transmit. In this state, you can click this button to start 
transmitting.  

XMIT - This indicates that the radar is currently transmitting. In this state, you can click this button to 
place the radar in standby mode (which turns off the transmitter).  

The radar status/control button (to the right of the Transmit/Standby button) will only appear when the radar is 
transmitting. It displays the status of the major radar controls, which are:  

SP/LP - Short or Long Pulse Length. This indicator will be dim for short pulses and bright for long pulses.  

EXP - Target Expansion. This indicator will be dim when target expansion is off and bright when it's on.  

IR - Interference Rejection. This indicator will be dim when IR is off, otherwise it will be bright and 
include the level of rejection (1, 2, or 3).  

GAIN - This will be the word "AUTO" or a bar graph indicating the level of gain.  

SEA - This will be the work "AUTO" or a bar graph indicating the level of sea clutter removal (STC).  

RAIN - This will be the work "AUTO" or a bar graph indicating the level of rain clutter removal (FTC).  
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Clicking on the radar status/control button changes the main menu into the radar control menu which is where 
you can change any of these settings. To get back to the main menu, just wait a few seconds or click in the 
background area of the radar control menu. 

Radar Setup  
Before the radar is used, various settings should be calibrated and this is done using the Radar Controls Task 
Pane. To access the Radar Controls Task Pane, click on the title of the Task Pane and select Radar Controls from 
the menu.  

The Radar Controls Task Pane is made up of several pages. The first page includes several options and buttons 
that will display other pages. The options here include:  

Main Bang Suppression - Enabling this erases the strong returns immediately surrounding your vessel 
(the "Main Bang").  

Auto Range - Enabling this option will cause the radar's range to be determined by the chart views that 
include the radar overlay. If you are trying to use the radar-only view and the range controls aren't 
working, it's probably because this option is checked! This will be changed in the final product to 
somehow make it easier to switch between automatic and manual range setting.  

Reset - This button will reset all radar related settings to their defaults.  

Tuning - This buttons displays the Tuning page which lets you fine-tune the radar receiver. This should 
not ever be needed and the option will probably not be included in the final product.  

Initial Setup - This button displays the Initial Setup page which is where all the calibration settings can 
be found. These settings include:  

Heading Line - This is used to compensate for an antenna that was not installed at exactly the right 
angle.  

Parking Angle - This is used to cause the radar antenna to stop at a particular angle when placed in 
standby mode.  

Trigger Delay - This is used to compensate for the length of the cable connecting the radar antenna to 
the control box and other things that affect the range calibration. It is very important that the trigger 
delay be calibrated correctly. If it is not, targets will not appear at the correct range and the radar image 
will not line up with the chart.  

Auto STC Preset and Harbor STC Preset - These values calibrate the automatic sea clutter (STC) for long 
(auto) and short (harbor) ranges.  

Manual STC Preset - This value calibrates the manual sea clutter (STC) control. It is effectively the 
"coarse" control while the primary control on the radar control menu is the "fine" control.  

STC Curve Preset - This value calibrates the STC controls to the height of the antenna.  

Auto Gain Preset - This is used to calibrate the automatic gain function.  

Manual Gain Preset - This is used to calibrate the manual gain function. It is similar to the Manual STC 
Preset in that it effectively provides a coarse adjustment.  

When you select one of the Initial Setup values to adjust, you will see instructions for making the adjustment in 
the task pane. Some of the settings require your vessel to be out on the water under certain conditions.  
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The Radar-Only View 

 

Coastal Explorer’s radar-only view looks and works very much like a typical radar. In this display, your vessel is 
represented by the small circle in the middle and the radar returns are shown as orange. This particular screen 
shot also includes range rings, a couple of AIS targets which appear as red triangles, a heading line which is the 
vertical line above the boat, a stern line which is the dashed line below the boat, a North marker which is the 
small solid line around the 43° mark. 

To open a radar-only view: 
1. split the screen into more than one chart view using the 2, 3, or 4 keys 
2. Right-click on a view other than the Primary Chart View 
3. Select Radar from the popup menu 

The radar-only view can be changed back to a chart view by right-clicking anywhere in the radar image and 
selecting Chart from the menu.  

The Radar View Toolbar 

The radar-only view has a toolbar with the following options:  

Orientation - This button indicates the currently selected orientation. Click the button to cycle through 
the options, which are:  

H UP - Heading Up 

C UP - Course Up 

N UP - North Up  
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Range - This control lets you adjust the range.  

Info - This buttons displays a menu of things that can be displayed on top of the radar such as range 
rings, bearing lines (EBL), range markers (VRM), guard zones, etc.  

Off Center Display 

You vessel's location is indicated by a small circle in the center of the radar range circles. You can create an off-
center display by dragging this circle around the view with your mouse. Double-clicking on this circle will cycle 
between centered and look-ahead modes.  

REVIEW: Need a lot more information here! Including all the display options, using the radar tools, etc. 
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The Radar Chart Overlay 

The radar image can be displayed as an overlay on a chart viewer. To enable or disable the radar overlay, right 
click on the chart and select the Radar Overlay option, or click on the Chart Viewer Toolbar's Info button and 
select Radar Overlay from that menu.  

In order for the radar image to line up with the chart, Coastal Explorer must have an accurate vessel position 
and heading input and the Trigger Delay must be calibrated correctly. Just about any GPS is going to position 
your vessel close enough to the right location that GPS accuracy is not usually an issue. However, slightly 
incorrect headings can cause very large and noticeable misalignment of the radar and chart.  

Most electronic compasses have some sort of setup procedure for building internal magnetic deviation tables 
which can increase the accuracy of the heading reported by the compass. Please refer to the installation manual 
for your compass to find the appropriate procedure (which usually involves moving the boat slowly through a 
few tight circles). You should also follow our procedure for adjusting the Trigger Delay to make sure that target 
ranges are correctly represented.  

If you do not have an electronic compass (or your compass is not very accurate), it is still possible to use the 
radar overlay but it is important to understand certain limitations. Since the radar image is inherently relative to 
your vessel's heading and the chart is inherently North Up, Coastal Explorer must use your heading to rotate the 
radar image in order to line it up with the chart. If Coastal Explorer is not receiving a heading, then it will use the 
course-over-ground value from your GPS instead. A vessel's course over ground is usually the same as its 
heading, except when the vessel is crabbing, turning, moving slowly, or stationary. At those times that the 
course over ground is not the same as the heading, the radar image will not line up with the chart. In many 
cases, though, that doesn't matter as much as it might seem because the human brain is very good at making 
the mental adjustment necessary to determine how the radar should line up with the chart.  

Radar Tools on the Overlay 

Radar tools such as range rings, variable range markers (VRM) and electronic bearing lines (EBL) can be 
displayed on the chart along with the radar image. These tools can be individually selected by right-clicking on 
the chart, select the Radar Tools option from the popup menu, and selecting a tool from the sub-menu.  
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Options and 
Reference 
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Options Window 

Tools > Options 

The options window provides you with access to most of Coastal Explorer's option settings. 

The options window is split into several pages of settings and a page index is listed on the left side of the 
window. Click on a page in the index to display that page of options. 

TIP: If you prefer to use your keyboard, the Ctrl+PageUp key will select the previous page of options and 
Ctrl+PageDown will select the next page. 

The options window contains a Reset button which can be used to reset most options to the "factory defaults". 
(This button will not, however, reset your Instrument Ports or Chart Folder options.) 

The pages of the options window include: 

 Measurements Controls units of measurement and value formatting options.  

 Instruments Controls NMEA 0183 port settings for your GPS, autopilot, etc.  

 Charts Controls where and how charts are installed and quilted.  

 Alerts Controls voice alerts for various events that occur while cruising.  

 AIS Controls the display of AIS targets and determines which targets are dangerous.  

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Opt_Measurements.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Opt_Instruments.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Opt_Charts.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Opt_Alerts.htm
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Opt_AIS.htm
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Measurement Options 

Tools > Options > Measurements 

This option page allows you to select which units to display values in. These settings will affect the values 
displayed just about everywhere in Coastal Explorer, including on vector charts, but not on raster or photo 
charts. 

TIP: You may quickly select all of the English or Metric options by pressing the Select All English Settings 
or Select All Metric Settings buttons. 

Distances 
Distances may be displayed as any of these: 

 Kilometers and Meters  

 Feet  

 Yards  

 Nautical Miles  

 Nautical Miles and Yards  

 Nautical Miles and Feet  

 Statute Miles  

 Statute Miles and Yards  

 Statute Miles and Feet  

The Nautical Miles and Yards and Statute Miles and Yards options will show distances larger than ¼-mile in 
miles and smaller distances in yards. 

The Nautical Miles and Feet and Statute Miles and Feet options will show distances larger than ¼-mile in miles 
and smaller distances in feet. 

Depths 
Depths may be displayed as any of these: 

 Meters  

 Feet  
 Fathoms  

 Fathoms and Feet  

The Fathoms and Feet option will display fractions of a fathom as feet. 

Heights 
Heights may be displayed as either of these: 

 Meters  

 Feet  
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Speeds 
Speeds may be displayed as any of these: 

 Kilometers per Hour  

 Knots  

 Miles per Hour  

Temeratures 
Temperatures may be displayed as either of these: 

 Celsius  

 Fahrenheit  

Volumes 
Fuel volumes may be displayed as any of these: 

 Liters  

 Gallons  

Locations 
Locations consist of a latitude and a longitude and may be displayed in any of these formats: 

 Degrees, Minutes, and Seconds  

 Degrees and Minutes  

 Degrees  

Times 
Times may be displayed in either of these formats: 

 24-hour  
 12-hour (AM/PM)  

Bearings 
Bearings may be display as either of these: 

 True  

 Magnetic  
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Alert Options 

Tools > Options > Alerts 

This option page allows you to control which events cause alerts and the sounds or voice used to deliver them to 
you. 

The various alerts are: 

 Course update at waypoints Selecting this option will cause an alert whenever you reach a waypoint. 
The alert will include the bearing to the next waypoint.  

 Boundary crossing Selecting this option will cause an alert when a boundary area or circle is crossed.  

 Depth above Selecting this option and entering a depth value will cause an alert whenever the depth 
goes above the depth value. This feature depends on a working depth sounder connected to the NMEA 
port.  

 Depth below Selecting this option and entering a depth value will cause an alert whenever the depth 
goes below the depth value. This feature depends on a working depth sounder connected to the NMEA 
port.  

 XTE over Selecting this option and entering a distance value will cause an alert whenever the cross-
track-error exceeds the distance.  

 Obstacles (vector charts only) Selecting this option and entering a Look ahead time period value 
(minutes and/or seconds) will cause an alert when a new obstacle is found on the path between your 
boat and the point looking that far ahead of your boat at your current speed.  

Speakers 
Coastal Explorer normally uses a PC's "internal speaker" to sound alarms because these speakers cannot be 
turned off and are not affected by volume controls. However, some computers do not have an internal speaker, 
so Coastal Explorer can be configured to use normal speakers instead. You can use the Test Beeper button to 
determine if your computer has an internal speaker; press the button and listen. If you hear a beep, then your 
PC does have internal speakers. If you do not hear a beep, select the Use default playback device option and 
make sure your volume is set to a level appropriate for the alarms you want to be able to hear. 

Voice 
The voice used to deliver alerts may be controlled with these options: 

 Enable Voice Alerts Selecting this option allows the voice to be used  

 Which voice Selects the voice to use  

 Time between alerts Selects the amount of time to wait between alerts. This must be one or two 
numbers followed by the letter m for minutes, or s for seconds.  

 Volume Selects the volume of the voice relative to other sounds. You may need to adjust the volume 
control of your computer if the voice is not loud enough when this is all the way up.  

 Speech Rate Controls how fast the computer talks.  
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Units and Abbreviations 

The following table describes the units and abbreviations that may be used when entering values in Coastal 
Explorer. You may also use the plural form of most abbreviations (such as fms for fathoms). You may also use 
upper or lower case letters interchangeably. 

In most cases, you may enter measurements without specifying units. Coastal Explorer will assume you are using 
the units you have selected in the Measurements page of the Options Window.  

Distance, Depth, and Height 
NM nautical miles 

km kilometers 

mi miles 

yd yards 

ft feet 

in inches 

cm centimeters 

mm millimeters 

m meters 

fm fathoms 

Speed  
mph miles per hour  

kph or k/h kilometers per hour 

kn knots 

Temperature 
C Celsius 

F Fahrenheit 

Bearings 
T true 

M magnetic 

Periods of Time 
h or hr hours 

m or min minutes 

mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Opt_Measurements.htm
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s or sec seconds 

A period of time can include a combination of hours, minutes and seconds. For example: "3 hrs 15 mins" is a 
valid time period. If you do not specify a unit of time, then seconds are assumed, so "45" means 45 seconds.  

Time of Day 
The time of day may be specified as h:m, h:m:s where h, m, and s are replaced with the hour, minute, and 
second. An hour of 0 or 13-23 indicates 24-hour format and a suffix of am or pm indicates 12-hour format. An 
hour of 12 with no suffix is assumed to be noon. 

Locations 
A location is specified as latitude followed by longitude. You may specify each as a single number of degrees, 
two numbers of degrees and minutes, or three numbers of degrees minutes and seconds. You do not need to 
include the degree, minute, or second symbols after the numbers; as the number of numbers determines how 
they are interpreted. You may separate the numbers using spaces or hyphens. Before or after a latitude you 
must, however, include an N or S for north or south, and before or after a longitude you must enter an E or W 
for east or west. 

Here are some example locations you can enter (they all refer to the same place): 

 48°36.565'N 123°09.237'W  

 48 36.565 N 123 9.237 W  

 48-36.565 N 123-9.237 W  
 48°36'33.90"N 123°09'14.20"W  

 48 36 33.90N 123 09 14.20W  

 48-36-33.90N 123-09-14.20W  

 48.6094°N 123.1539°W  

 48.6094N 123.1539W  
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Keyboard Shortcuts 

Ctrl+N Create a New Navigation Object File 

Ctrl+O Open an existing Navigation Object File 

Ctrl+P Print 

  

Ctrl+A Select All 

Ctrl+X Cut 

Ctrl+C Copy 

Ctrl+V Paste 

Ctrl+Z Undo the last editing action 

Ctrl+Y Redo the last editing action 

Del Delete 

Alt+Enter Display the Properties Panel 

  

Arrow Keys Pan the chart view 

Shift+Arrow Keys Pan the chart view faster 

Page Up Pan the chart towards the vessel's heading (or course in Course Up mode) 

Page Down Pan the chart away from the vessel's heading (or course in Course Up mode) 

Ctrl+Right Rotate the chart view clockwise 

Ctrl+Left Rotate the chart view counter-clockwise 

+ Zoom the chart view In 

- Zoom the chart view Out 

U Cycle the chart orientation between North Up, Course Up, and Heading Up 

Home Center the chart view on the boat 

End Stop following the boat 
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B Cycle the "Bearing Display Mode" between True and Magnetic 

  

Tab Select the next Navigation Object 

Shift+Tab Select the previous Navigation Object 

Enter Activate the property window when a Navigation Object is selected 

Esc Hide the chart tip, cancel an operation that is in progress, or dismiss an active alarm 

  

F1 Get help 

F2 Edit the name of the selected Navigation Object 

  

F4 Man Over-Board 

F5 Add event mark at boat location 

F7 Add a new mark at the next click 

F8 Start adding a new route 

  

F9 Set a bookmark at the current viewing area 

F10 Go to the bookmark set with F9 

  

F11 Turn Full Screen mode on or off 

F12 Switch between Planning and Cruising modes 

  

Ctrl+F1 Turn the Task Pane on or off 

  

Ctrl+D or Alt+D Activate the find box on the toolbar 

Ctrl+F Find 

F3 Find Next 
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Shift+F3 Find Previous 

  

V Display only vector charts 

Shift+V Turn the display of vector charts on or off 

R Display only raster charts 

Shift+R Turn the display of raster charts on or off 

P Display only photo charts 

Shift+P Turn the display of photo charts on or off 

  

Ctrl+I Cycle between day, dusk, and night colors 

  

Space (3x) Reset to Standard Display (tap the spacebar quickly three times) 

1 Show one chart view 

2 Show two chart views 

3 Show three chart views 

  

C Show or hide the Tidal Current Predictions on the chart 

T Show or hide the Tide Level Predictions on the chart 

Shift+C Show the Tidal Current Prediction Browser Panel 

Shift+T Show the Tide Level Prediction Browser Panel 

  

W Skip the active waypoint and activate the next one from the active route 

Shift+W Activate the previous waypoint from the active route 

X Reset the Cross Track Error 

  

Ctrl+Shift+Up Speed the boat simulator up 
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Ctrl+Shift+Down Slow the boat simulator down 

Ctrl+Shift+Left Turn the boat simulator to port 

Ctrl+Shift+Right Turn the boat simulator to starboard 

  

The following keys require two key presses, Ctrl+Q followed by another key. The second key must be pressed 
less than one second after Ctrl+Q. These key combinations are intended to be used with programmable keypads 
and provide direct access to modes that are normally set by cycling through various options. 

Ctrl+Q C Select Course Up mode 

Ctrl+Q N Select North Up mode 

Ctrl+Q H Select Heading Up mode 

Ctrl+Q F Select Follow Boat mode 

Ctrl+Q A Select Look Ahead mode 

Ctrl+Q L Select Follow Leg-Line mode 

Ctrl+Q D Select Don't Follow mode 

Ctrl+Q S Select the Selection Mouse Tool 

Ctrl+Q Z Select the Zoom Mouse Tool 

Ctrl+Q P Select the Pan Mouse Tool 

Ctrl+Q M Display Magnetic Bearings 

Ctrl+Q T Display True Bearings 
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Getting Program Updates 

Help > Check for Updates 

This window helps you download and install updates to Coastal Explorer. 

You can get to this window with the Help > Check for Updates command. 

In order to ensure Coastal Explorer is always as good as it can be, we make regular updates to the software to fix 
bugs, add features, and make things easier to use. These updates are made available on our website and you 
can download them with a web browser if you need to copy them to a floppy disk or other removable storage 
device in order to get them to a computer that is not connected to the Internet. However, if your computer is 
connected, then you can download and install the latest update by simply using this window. 

Each Coastal Explorer program update is designed to contain all of the updates that came before it, so you don't 
have to worry about making sure you get every single one, but we do recommend that you update frequently so 
as not to miss out on the latest and greatest new features and fixes. 

Sometimes when you start Coastal Explorer it may tell you that it has an update that is ready to be installed; 
that's because it was able to download an update "in the background" the last time you were using the program. 
This can make installing an update take only a second or two! 

This window will display a list of all of the new updates that are ready for you to download and install (or let you 
know that none are available). Each update will have a short description and usually a link to the 
coastalexplorer.net web site for more details about what will change. 

When you click Install, Coastal Explorer will have to exit and restart in order to get updates. You will be asked if 
that's okay, and the process will be quick and automatic. 

The History button will show you a list of all of the updates you have installed so far.  

To get updates on a computer without an Internet connection: 
1. You will need to use another computer to download the update from: updates.coastalexplorer.net  
2. Follow the directions on that page to download the file to a floppy disk, USB Flash Drive, or other 

portable storage unit.  
3. Insert the portable storage device on the computer you want to update  
4. Use the Help > Check for Updates command.  
5. Coastal Explorer will now find the update, apply it, and restart itself.  

http://updates.coastalexplorer.net/
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Support Options 

You must register your copy of Coastal Explorer in order to receive technical support. You may register when 
you send us e-mail by including your full name and Product ID in the message. You can also register over the 
phone by calling the number below. 

Your Product ID may be found with the Help > About Coastal Explorer command.  

Your Coastal Explorer Support Options are: 
 Check the Coastal Explorer Network for answers at support.coastalexplorer.net  

 Send e-mail to support@rosepointnav.com, or  

 Call (425) 605-0985 Monday through Friday (except holidays), 9am to 5pm Pacific Time. Please have 
your Product ID ready!  

About Coastal Explorer Window 
Help > About Coastal Explorer 

Use this window to find information about your copy of Coastal Explorer, including: 

 the copyright message  

 what version of Coastal Explorer you are running  
 the product ID for your copy of Coastal Explorer  

 the End User License Agreement (EULA)  

Send Feedback 
Help > Send Feedback 

This window may be used to easily send feedback to Rose Point Navigation Systems. You may optionally include 
a screen shot (if it will help make your point) and/or your application log by checking the appropriate options. 

Feedback is sent using your email program and depends on having a MAPI-compatible email program (such as 
Outlook Express or Windows Mail) and an account profile already configured on your computer. If you use web-
based email or your email program is not MAPI compatible, then you can send your feedback to 
feedback@rosepointnav.com without using this command. 

While we do keep and review all feedback mail, we will not always respond. Please do not send feedback if you 
are in need of assistance, but contact our support department instead. 

 

http://support.coastalexplorer.net/
mailto:support@rosepointnav.com
mailto:feedback@rosepointnav.com
mk:@MSITStore:C:\Projects\Product\CE2\Setup_Zip\Program\Coastal%20Explorer.chm::/Support.htm
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